Announcement

Collapse
No announcement yet.

SMF 2.0 RC4 -> vB 4.1.1 -> attachments file system

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Zachery View Post
    That means mysql is down or otherwise unreachable. Are you sure mysql is up and taking connections?
    Probably mysql is down, but after a few hours of searching / google / ... trying one thing after the other to get mysql to respond, all I got was negative responses from mysql.

    Comment


    • #17
      A little more server information:


      Server Type Linux
      Web Server Apache v2.2.14
      PHP 5.3.2-1ubuntu4.7
      PHP Max Post Size 8.00 MB
      PHP Maximum Upload Size 50.00 MB
      PHP Memory Limit 256.00 MB
      MySQL Version 5.1.41-3ubuntu12.8
      MySQL Packet Size 32.00 MB

      I'm uploading the images again to the new server instance... Should I make changes to these settings?
      Last edited by Houseofdreams; Tue 25 Jan '11, 1:36pm.

      Comment


      • #18
        None of those should affect the connection issue.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          Originally posted by Steve Machol View Post
          None of those should affect the connection issue.
          Maybe not directly, but the connection is lost, during the import of the attachments in the database. Approx around 7.2 Gb(table size) and around 90.000 files... I now doubled the mysql packet size and the php memory limit, to see if this helps...

          Comment


          • #20
            Yes that may help. Also lowering the number you import per batch may help. In addition, this may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

            ini_set('memory_limit', -1);
            ini_set("max_execution_time", "2880");
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21
              Originally posted by Steve Machol View Post
              Yes that may help. Also lowering the number you import per batch may help. In addition, this may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

              ini_set('memory_limit', -1);
              ini_set("max_execution_time", "2880");

              Ok, changes made... A response will probably be posted tomorrow, as it's past midnight here now As soon as I have something, I will let you know.

              For now, thanks for all the help.

              Comment


              • #22
                Status update

                Allmost all attachments got imported (a few won't, but this is normal since some attachments are removed and so on) The attachments table is now 15.6 GB, my largest mysql until now

                I would think, that with these kind of numbers, storing the attachments to the filesystem again, would be appropriate? Any action to the database now, is extrmemely slow, so I'm going to give this a try and post my findings here.

                Comment


                • #23
                  Yes, you should absolutely store those attachments in the file system.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #24
                    I have another strange "problem":

                    All importing is done, but now I have the strange thing, that some attachments are attached more than once, but all point to the same image. The other strange thing avout this is, that the actually have different attachment id's. On the SMF forum, on that specific post, there's only one image / id.

                    Is there some kind of duplicate search function, or did I forgot some post-import action?

                    Comment


                    • #25
                      Never heard of that before. Sounds like a duplicate import. I don;t knwo any way to fix this except to start all over. However you can try the 'After the Import' instructions here:

                      http://www.vbulletin.com/docs/html/impex_cleanup
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #26
                        Originally posted by Steve Machol View Post
                        Never heard of that before. Sounds like a duplicate import. I don;t knwo any way to fix this except to start all over. However you can try the 'After the Import' instructions here:

                        http://www.vbulletin.com/docs/html/impex_cleanup
                        This was a clean install, everything done "by the book...".

                        I've done all the instructions posted on the page you mentioned... Very strange

                        Comment


                        • #27
                          Please report this in the vB4 Bug Tracker here:

                          http://tracker.vbulletin.com/secure/Dashboard.jspa
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #28
                            Originally posted by Steve Machol View Post
                            Please report this in the vB4 Bug Tracker here:

                            http://tracker.vbulletin.com/secure/Dashboard.jspa
                            Done. I entered all the data as good as I can....

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X