Announcement

Collapse
No announcement yet.

MySQL error on ImpEx first page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL error on ImpEx first page

    I have installed VBulletin on a test server and am trying to test an import from phpBB3. When I go to the ImpEx home page, I receive the following error message ...

    mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9

    mysql error number: 1064

    Date: Wednesday 05th 2011f January

    How can I correct this so that I can proceed?

    thank you very much for your assistance

  • #2
    SQL Syntax errors are almost always related to modified code or a bad file.

    To troubleshoot this, first reupload all the original vB Impex files.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      sorry, that didn't work either. I did an import 2 weeks ago and had no trouble at all.but then my server crashed, it had to be rebuilt and I have to start all over again. VBulletin installed just find but now I'm getting this "There seems to have been a problem with the database." error as soon as I try and start the import

      Comment


      • #4
        We need to see the real error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          <html><head><title>ImpEx Database Error</title><style type="text/css"><!--.error { font: 11px tahoma, verdana, arial, sans-serif; }--></style></head>
          <body></table></td></tr></table></form>
          <blockquote><p class="error">&nbsp;</p><p class="error"><b>There seems to have been a problem with the database.</b><br />
          <form><textarea class="error" rows="15" cols="100" wrap="off">ImpEx Database error

          mysql error: Invalid SQL: CREATE TABLE vb_impexerror (
          errorid bigint(20) unsigned NOT NULL auto_increment,
          errortype varchar(10) NOT NULL default '',
          classnumber varchar(3) NOT NULL default '',
          importid bigint(20) NOT NULL default 0,
          error varchar(250) default 'NULL',
          remedy varchar(250) default 'NULL',
          PRIMARY KEY (errorid)
          ) TYPE=MyISAM

          mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9

          mysql error number: 1064

          Date: Wednesday 05th 2011f January 2011 12:48:37 PM
          Database: vbulletin
          MySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9
          </textarea></form></blockquote>

          </body></html>

          Comment


          • #6
            Nothing wrong with that Query from what I can tell. Run .../impex/help.php and choose to clear the imported data and session. Then try again.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              that gives me the following error ...

              ImpEx Database error

              mysql error: Invalid SQL: DELETE FROM datastore WHERE title='ImpExSession';

              mysql error: Table 'vbulletin.datastore' doesn't exist

              mysql error number: 1146

              Date: Wednesday 05th 2011f January 2011 01:10:19 PM
              Database: vbulletin
              MySQL error: Table 'vbulletin.datastore' doesn't exist

              Comment


              • #8
                Check the database. Does that table exist? Are you using a table prefix?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  ok, yes you are correct, the datastore table was actually vb_datastore and I did not have the prefix correctly entered in the Impex.config.php file so now I can delete sessions, etc from the help.php page but then I get the same MySQL error. I've even deleted the database, reinstalled VBulletin again and no luck.

                  Comment


                  • #10
                    ok, here's what I've done now -- this is just my backup VBulletin server. I have a different server for my live site (which is not yet live as we're still running off the phpBB3 forum on another server). And, we won't be going live on the new VBulletin server until we're ready so -- the import on that is going just fine. My question now is ... I have done an import to the new VBulletin server I have. If, in a week, I want to do another final import with the most current data in my phpBB4 database, will a 2nd import automatically over-write the first import or should I use the "Delete importids" link from the help.php page?

                    Comment


                    • #11
                      No sorry. The import will import all data, not just new data.For this reason you should do the import just once.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X