Announcement

Collapse
No announcement yet.

phpBB2 to vBulletin Suite problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    Good to hear

    Leave a comment:


  • vbresults
    replied
    The import went through successfully after upgrading from phpBB2 to phpBB3, and then importing phpBB3 into vB4.

    Leave a comment:


  • vbresults
    replied
    This is ridiculous. I am going to try updating to phpBB3 and then vB4; maybe the problem is specific to the phpBB2 modules.

    Leave a comment:


  • Zachery
    replied
    Assuming your system has the resources, double or trippling available memory buffers during an import can help.

    Leave a comment:


  • vbresults
    replied
    Added my.cnf.

    Leave a comment:


  • vbresults
    replied
    Originally posted by Steve Machol View Post
    What do you mean? Did you ollow the 'After the Import' instructions here:

    http://www.vbulletin.com/docs/html/impex_cleanup
    Yes. I had 35K threads with empty firstpostusernames+userids (& lastpostusernames+userids), and 360K posts with empty postusersnames+userids.

    After rebuilding forum and thread information many times, all I could do was map these user-orphaned threads and posts to a new user, then delete this user so the posts appeared to be posted to by guests.

    /etc/mysql/my.cnf
    Code:
    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock
    
    
    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0
    
    [mysqld]
    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    language = /usr/share/mysql/english
    skip-external-locking
    skip-name-resolve
    bind-address = 192.168.1.201
    key_buffer = 256M
    max_allowed_packet = 16M
    thread_stack = 192K
    thread_cache_size = 32
    myisam-recover = BACKUP
    max_connections = 100
    table_cache = 1536
    table_definition_cache = 1024
    thread_concurrency = 4
    query_cache_type=1
    query_cache_limit = 1M
    query_cache_size = 24M
    query_cache_min_res_unit = 2K
    join_buffer_size = 256K
    open_files_limit = 2500
    low_priority_updates = 1
    log_slow_queries = /var/log/mysql/mysql-slow.log
    expire_logs_days = 10
    max_binlog_size = 100M
    
    
    
    [mysqldump]
    quick
    quote-names
    max_allowed_packet = 16M
    
    [mysql]
    
    [isamchk]
    key_buffer = 16M
    Last edited by vbresults; Thu 3rd Feb '11, 9:53am. Reason: Added my.cnf

    Leave a comment:


  • Steve Machol
    replied
    What do you mean? Did you ollow the 'After the Import' instructions here:

    http://www.vbulletin.com/docs/html/impex_cleanup

    Leave a comment:


  • vbresults
    replied
    Why are 35K of my threads and 360K of my posts not mapped to a user? Is this another bad import?

    Click image for larger version

Name:	import_statistics.jpg
Views:	1
Size:	42.0 KB
ID:	3681320
    Last edited by vbresults; Thu 3rd Feb '11, 5:05am. Reason: Added import summary.

    Leave a comment:


  • vbresults
    replied
    I skipped avatar imports suspecting it might slow down the process. That and because of the warning next to the option.

    Leave a comment:


  • Zachery
    replied
    Are you trying to import avatars? If so, skip it. Let users re-upload their avatars. Iwll save you a ton of time.

    Leave a comment:


  • vbresults
    replied
    Threads and posts are cruising along well at around 3-5 minutes per 20,000, so this looks like an issue with the user module, not the database configuration. Regardless, I will be attaching my.cnf soon.

    Leave a comment:


  • Zachery
    replied
    Whats your my.cnf look like for mysql?

    Leave a comment:


  • vbresults
    replied
    PHP memory limit at 256MB, MySQL memory limit and Squid+Apache timeouts high, but this is still crawling along very slowly (3-4 hours per cycle). Doing 10K users per cycle (out of 200K). Is there any way to speed this up? I enabled 'shortoutput' and am confident the posts will fly through at these resource limits (and following the big board instructions), but why are users going so slow?

    Leave a comment:


  • Project-Buckfast
    replied
    Alternatively you could run the import on your local machine, then upload the resulting database. Should be faster that way.

    Leave a comment:


  • Zachery
    replied
    It shouldnt take anywhere near 72 hours to do an import of that size. Maybe 3-6 hour. Do larger groups and up php and mysql's memorys limits if you can.

    Leave a comment:

Related Topics

Collapse

Working...
X