Announcement

Collapse
No announcement yet.

Importing stories from Drupal 6 does nothing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • aaziz
    replied
    Originally posted by Trevor Hannant View Post
    I've raised a bug for this here:

    http://tracker.vbulletin.com/browse/IMPX-412

    Something is stopping an option from displaying within Impex which then causes the article import to fail - I've referred it up the line to see if we can get Developer time allocated to this



    Sorry to bring this up again, but I've similar bug (though not the same as this one), and also found a fix.

    impex\systems\drupal_6_cms\004.php:

    PHP Code:
                // Start up the table
                
    $displayobject->update_basic('title'$displayobject->phrases['import_cms_article']);
                
    $displayobject->update_html($displayobject->do_form_header('index',substr(get_class($this) , -3)));
                
    $displayobject->update_html($displayobject->make_hidden_code(substr(get_class($this) , -3),'WORKING'));
                
    $displayobject->update_html($displayobject->make_table_header($displayobject->phrases['import_cms_article']));

                
    // Ask some questions
                
    $displayobject->update_html($displayobject->make_input_code($displayobject->phrases['units_per_page'], 2000));  // <-- THIS LINE IS MISSING A PARAMETER... NAMELY THE "name" OF THE INPUT ELEMENT
                
    $displayobject->update_html($displayobject->make_select_input_code('Enter the node type you want to import as an article''node_type',
                                   
    $this->drupal6_cms_get_node_types(
                                        
    $Db_source,
                                        
    $sessionobject->get_session_var('sourcedatabasetype'),
                                        
    $sessionobject->get_session_var('sourcetableprefix')
                                   )
                            )
                    ); 
    Should become:

    PHP Code:
                // Start up the table
                 
    $displayobject->update_basic('title'$displayobject->phrases['import_cms_article']);
                 
    $displayobject->update_html($displayobject->do_form_header('index',substr(get_class($this) , -3)));
                 
    $displayobject->update_html($displayobject->make_hidden_code(substr(get_class($this) , -3),'WORKING'));
                 
    $displayobject->update_html($displayobject->make_table_header($displayobject->phrases['import_cms_article']));
     
                 
    // Ask some questions
                 
    $displayobject->update_html($displayobject->make_input_code($displayobject->phrases['units_per_page'],  'perpage'2000)); // <-- ADD THE 'perpage' INPUT ELEMENT NAME HERE
                 
    $displayobject->update_html($displayobject->make_select_input_code('Enter the node type you want to import as an article''node_type',
                                    
    $this->drupal6_cms_get_node_types(
                                         
    $Db_source,
                                         
    $sessionobject->get_session_var('sourcedatabasetype'),
                                         
    $sessionobject->get_session_var('sourcetableprefix')
                                    )
                             )
                     ); 
    I'm going to create an issue and suggest that as the patch, but though everyone should know This post led me to check the output code since the "units per page" wasn't actually displaying at all with a value.

    EDIT: Issue created here: http://tracker.vbulletin.com/browse/IMPX-415
    Last edited by aaziz; Thu 9th Aug '12, 3:53am.

    Leave a comment:


  • Trevor Hannant
    replied
    I've raised a bug for this here:

    http://tracker.vbulletin.com/browse/IMPX-412

    Something is stopping an option from displaying within Impex which then causes the article import to fail - I've referred it up the line to see if we can get Developer time allocated to this

    Leave a comment:


  • Chris27
    replied
    Importing stories from Drupal 6 does nothing

    Excellent. I'll give it a shot. Thanks Jake.

    Leave a comment:


  • Jake Bunce
    replied
    Originally posted by Chris27 View Post
    I received the following error message when attempting to use the CMS import.

    ImpEx Database error


    mysql error: Invalid SQL:
    SELECT node.nodeid
    FROM cms_article AS article
    INNER JOIN cms_node AS node ON (article.contentid = node.contentid AND node.contenttypeid = 24)
    WHERE article.importcmscontentid <> 0



    mysql error: Unknown column 'article.importcmscontentid' in 'where clause'


    mysql error number: 1054


    Date: Thursday 15th 2012f March 2012 12:00:23 AM
    Database: computer_vB
    MySQL error:
    I encountered similar errors with the Wordpress CMS importer. ImpEx is failing to creating the import columns in the vB database. I fixed it by manually creating the columns. Here are the queries I had to run to create all of the CMS import columns:

    Code:
    ALTER TABLE cms_article ADD importcmscontentid INT UNSIGNED NOT NULL DEFAULT '0';
    
    ALTER TABLE cms_node ADD importcmsnodeid INT UNSIGNED NOT NULL DEFAULT '0';
    
    ALTER TABLE cms_nodeinfo ADD importid INT UNSIGNED NOT NULL DEFAULT '0';

    Leave a comment:


  • Chris27
    replied
    I received the following error message when attempting to use the CMS import.

    ImpEx Database error


    mysql error: Invalid SQL:
    SELECT node.nodeid
    FROM cms_article AS article
    INNER JOIN cms_node AS node ON (article.contentid = node.contentid AND node.contenttypeid = 24)
    WHERE article.importcmscontentid <> 0



    mysql error: Unknown column 'article.importcmscontentid' in 'where clause'


    mysql error number: 1054


    Date: Thursday 15th 2012f March 2012 12:00:23 AM
    Database: computer_vB
    MySQL error:

    Leave a comment:


  • Chris27
    replied
    Hi Guys - I'm back to trying this again. So far I've found the CMS import broken as usual. However, the Forum import seems to import all my Drupal CMS categories. It would be nice to know what the difference is between importing to the vB forum or vB CMS and other things surrounding impex and Drupal.

    Anyone know of a guide?

    Leave a comment:


  • amaiman
    replied
    None that I've heard about. I last tried a month or two ago, it was still behaving exactly the same (nothing imported). I wouldn't hold your breath. My current plan is to ditch the VB CMS altogether and use Drupal for CMS, and just use VB for forums. There's no easy way to do that, though, and I haven't had time to write code for it, so my site is indefinitely stalled on the transition. So far my VB license has been a big waste of money...

    Leave a comment:


  • GT-
    replied
    Has there been a solution to this yet?

    I've downloaded the ImpEx scripts and already had to make a code change to keep up with MySQL 5.5, only to discover the same issue?

    My source on this occasion is vbDrupal, which is based on Drupal 5, not 6!

    Leave a comment:


  • GT-
    replied
    Has there been a solution to this yet?

    I've downloaded the ImpEx scripts and already had to make a code change to keep up with MySQL 5.5, only to discover the same issue?

    My source on this occasion is vbDrupal, which is based on Drupal 5, not 6!

    Leave a comment:


  • amaiman
    replied
    Good luck with that. I did exactly that months ago (support ticket), and all support did was insist that it "worked for them" even though it never did on my server or a completely clean new testing server.

    Impex is broken and there doesn't appear to be anyone actually working on it or who knows how to fix it.

    Let me know how your ticket goes. If they don't fix it, I encourage you to pursue a refund on your purchase price.

    Leave a comment:


  • Steve Machol
    replied
    Fill out a support ticket at:

    http://members.vbulletin.com/members...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.

    Leave a comment:


  • Chris27
    replied
    I just purchased vBulletin 4.0 Publishing Suite and want to move from Drupal 6 to vB CMS and Forums. I used impex and ran into the same problems described above. Is there seriously no fix for this issue?

    Leave a comment:


  • The Rocketeer
    replied
    Originally posted by amaiman View Post
    Nope, I gave up. He kept writing back once a week saying it was fixed, but it never worked, even when I tried it on a clean server/clean installation. They don't have any full-time developers working on impex and I've gotten the sense that VB management doesn't care about the feature. They already have our money.
    You know, I agree with you, Look at these ImpEX forums, NO SUpport!! They have this Jerry guy who's Im not even sure if hes doing his Job Right. 6 Months to have CMS Support = 0? I mean this is a sick joke VBs playing on us, We Paid for a Publishing Suite, what we got was a half baked software that makes promises it cant keep. At least not timely to be worth while.

    Now Im stuck and I dont know how to switch to VB, I tried Joomla > Drupal > VB // Nope.. NO CMS SUPPORT>

    I tried to import Dupal 6 to Vbulletin, Didnt work..Same Error....

    Importing 0 nodes

    From : 0 :: To :

    0 stories imported.

    Leave a comment:


  • amaiman
    replied
    Originally posted by The Rocketeer View Post
    Did u even get this solved ? I dont think Jerry keeps up the pace as much as the rest of VB development goes, no CMS Support
    Nope, I gave up. He kept writing back once a week saying it was fixed, but it never worked, even when I tried it on a clean server/clean installation. They don't have any full-time developers working on impex and I've gotten the sense that VB management doesn't care about the feature. They already have our money.

    Leave a comment:


  • The Rocketeer
    replied
    Did u even get this solved ? I dont think Jerry keeps up the pace as much as the rest of VB development goes, no CMS Support

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X