Announcement

Collapse
No announcement yet.

ImpEx don't working, errors in SQL requests

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImpEx don't working, errors in SQL requests

    I have tried to import SMF to VB 4 and receive lot of errors on first importing step
    It's really easy and stupid errors, I can't understand why it exsists in costly forum software.

    ImpEx Database errormysql error: Invalid SQL:
    INSERT INTO vb_usergroup
    (
    importusergroupid, title, description,
    usertitle, passwordexpires, passwordhistory,
    pmquota, pmsendmax,
    opentag, closetag, canoverride,
    ispublicgroup, forumpermissions, pmpermissions,
    calendarpermissions, wolpermissions, adminpermissions,
    genericpermissions, genericoptions, attachlimit,
    avatarmaxwidth, avatarmaxheight, avatarmaxsize,
    profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize,
    signaturepermissions, sigpicmaxwidth, sigpicmaxheight,
    sigpicmaxsize, sigmaximages, sigmaxsizebbcode, sigmaxchars,
    sigmaxrawchars, sigmaxlines
    )
    VALUES
    (
    '69',
    'Imported Users',
    'Usergroup description',
    '',
    0,
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    ''
    )


    mysql error: Incorrect integer value: '' for column 'passwordhistory' at row 1

    mysql error number: 1366

    Date: Sunday 28th 2010f February 2010 08:57:08 AM
    Database: newstavnet
    MySQL error:
    ImpEx Database errormysql error: Invalid SQL: SELECT * FROM smf_membergroups ORDER BY ID_GROUP LIMIT , 50

    mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 50' at line 1

    mysql error number: 1064

    Date: Sunday 28th 2010f February 2010 09:13:38 AM
    Database: stavnet
    MySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 50' at line 1
    vBulletin - по русски

  • #2
    It solved by config, but this is not clear
    vBulletin - по русски

    Comment


    • #3
      Why not post the resolution if you expect others to help you in the future. I'm having the same problem. I've got a SMF 1.11 database trying to upgrade to vb Community 4.03.

      I select option 3 to Import UserGroups The only difference mine is inserting into a table usergroup instead of vb_usergroup.

      Comment


      • #4
        I found sort of a mention of this in another thread. I disabled strict mode for MySql and it worked.

        You can do it in the my.ini of the MySQL installation folder.

        # Set the SQL mode to strict
        #sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
        sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

        I commented out the original line as you see above and then added a new one without STRICT_TRANS_TABLES

        Did the trick.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X