No announcement yet.

Attachment Import Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment Import Problem

    I have just installed VB 4.0 PL1, and have been working on importing my old forum data into VB. I have gotten everything imported and working properly with the exception of the attachments. Here are the details:

    * Importing from a PostNuke/PNPHPBB2 board using ImpEx 1.94

    * All posts, users, threads, forums, etc. imported without issues

    * Forum contains over 115,000 posts and about 600MB of attachments

    * I have checked and re-checked the full path issue that is so commonly a problem with attachment imports, and I am pretty certain that I have it correct. I have verified it numerous times using the SSH and pwd method.

    * Attachments for old board are hosted on a seperate web server from the old board (same physical server)

    * Attachments are set to be stored in file system in VB, with a proper storage path

    The error I am seeing is the same old 'Source file not found' error that usually points to an incomplete path. The only thing I can think of is that ImpEx is having trouble because the attachments are stored on a seperate web server than the old board.

    I hve tried copying the attachments directory up to the same web server as the board (and changing the path appropriately), but that didn't help either.

    Any ideas?

    Click image for larger version

Name:	attachmenterror.JPG
Views:	1
Size:	24.0 KB
ID:	3714139

  • #2
    Really hoping someone can help me here. I am at a loss, and this is the only thing keeping me from moving forward with VB4.

    Is the fact that the images are stored on a separate web server an issue?


    • #3
      have you tried importing them into the vb database rather than the file system

      you are using /home/username/public_html/forum/attachment path of your old forum instead of of your old forum in impex attachment module


      • #4
        I haven't tried importing them to the database. I don't really want to store them there. I guess I could give that a shot, although the error really looks like it can't find the source file.

        I am using the correct path (similar to your first example), and have verified it using the SSH/pwd method.


        • #5
          I'm having the same problem and its driving me crazy. I've got almost 10,000 attachments and I'm in the process of downloading them so I can upload them to the new forum location and try an import that way.


          • #6
            I just found the solution. I needed to have the server path correct. For me it was /home/~ftp user name~/forums/images/attachments . Once I did this it imported flawlessly!

            Using does not work, which is strange because it worked for importing avatars and sig pics.


            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.