Announcement

Collapse
No announcement yet.

phpBB3 to VB4PL1 attachment importing issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bogley
    replied
    OK, thanks Zachery, that's what I was going to try next. One last question... what is involved in the upgrade from 3.8.4 to 4.0.1? Is it pretty much just an overwrite of all the files on my FTP client? If so, what happens to my customized default style, things like that?
    Thanks for your quick response by the way.

    Leave a comment:


  • Zachery
    replied
    As a work around, import your phpbb board to vb 3.8 for the time being and then upgrade.

    Leave a comment:


  • bogley
    replied
    I am having very similar problems and getting NOWHERE on the forums, and I've put in a few tickets too.

    I'm importing from phpbb 2 to vb 4.0.1. Like everybody is saying, the import goes smooth up until the attachments.

    I'm choosing to store my attachments in a file system. I'm pointing to my correct original attachment source which is /var/www/vhosts/bogley.com/httpdocs/forum/files and I'm getting the error message of:
    Failed :: Attachment not importedattach file 2

    So ysam, I understand that you're coming from phpbb 3, but do you think I can make that same edit you did to ImpExDatabase_400.php and make some progress?

    Sorry, I'm a noob at php stuff. Thanks for the help, there's been some good info in this thread so far.

    Leave a comment:


  • ysam
    replied
    Well, did you open a Trouble Ticket? It comes that when you post it here you expect to find help from the community but you still have the option to open a ticket and support will help you on that. I am not sure if support covers impex though. I don't see why not.

    Leave a comment:


  • MURRAY
    replied
    I just cannot understand why I cannot get a simple answer that will make my system work from the people who gladly took my $300.00 US for a licence. It is getting just a little frustrating. I have been trying to do this for over a month , countless deletes and download again, then upload again, and all I need is some person who is supposed to know to give the info I need.
    Is that too much to ask ?

    Leave a comment:


  • ciaba
    replied
    hi, i've the same problem, i'm trying to import attachments from phpbb3 to vb4 but impex misses every file as you can see from the screenshot

    Click image for larger version

Name:	Schermata 2010-01-18 a 14.37.42.jpg
Views:	1
Size:	29.2 KB
ID:	3677725

    usually attachments in phpbb are accessed with this kind of address www.***.com/forum/download/file.php?id=3022 but i've no idea of how to set option "Full path to uploads/attachments folder where the source attachments are." in impex.

    any suggestion?

    Leave a comment:


  • MURRAY
    replied
    After several more attempts I still cannot work out the correct path for attachments. This may be simple stuff to you wizz kids but to an ordinary bloke I am finding it most frustrating. The import goes ever so well up until attachments.
    Can some compassionate soul please give me a sample path.
    My phpbb3 data base and the new VB data base are on the same server, surely there is somebody out there who can tell me..........

    Leave a comment:


  • Bodero
    replied
    Okay, I should really keep playing around before I post something here. By setting the number to process per page to 25 instead of 300, now it works. Problem is, the attachments are there, or at least it says it is... but they aren't in the posts.

    Leave a comment:


  • Bodero
    replied
    Found a semi-solution, I realized because I had the option for storing attachments in the filesystem instead of database enabled, this occurred.

    I set it back to the database and it says they imported fine - however I don't see them on threads with attachments. The files are in the DB though.

    Now my DB is over its storage limit and I'm trying to switch it back to filesystem and I get this error:

    Fatal error: Out of memory (allocated 5767168) (tried to allocate 238782 bytes) in /homepages/xx/dxxxxxxxxx/htdocs/forum/includes/class_core.php on line 2277

    Leave a comment:


  • Bodero
    replied
    I also have the same issue, though with phpBB2. I just purchased Vb 4 however and have never ran 3.x, so installing 3.x only to upgrade to 4.0 seems like a ton of work.

    Was there a method posted that will definitely make the attachment import script work for phpBB2 -> VB4?

    Leave a comment:


  • ysam
    replied
    Yes. Just run impex and import your phpbb3 on lastest VB3.8. Everything is fine. Then upgrade to v4.0.1. My only problem is some duplicate users (user and imported_user which I deleted) and the user avatars. Everything else including attachments imported correctly.

    Leave a comment:


  • MURRAY
    replied
    Just to be clear, if I install 3.8, then import phpbb3 using IMPEX it will work bringing in the the attachments ???? and finishing everything off just fine ????

    I have tried several times to import phpbb3 into VB 4 and everything runs fine until I get to attachments and it will not do it.

    Leave a comment:


  • ysam
    replied
    That's what I did... it works.. no avatars but it works..

    Leave a comment:


  • RMonster
    replied
    Hmmm. Since there's no response to this problem i'm going to try to Impex phpbb -> vb3.8 then upgrade to 4.0.

    A bit silly but i have to get it done.

    Leave a comment:


  • ysam
    replied
    You did it in VB4.0.0PL1 and impex 1.94? How back in time can this be?

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X