Announcement

Collapse
No announcement yet.

phpBB3 to VB4PL1 attachment importing issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • phpBB3 to VB4PL1 attachment importing issue

    Hi there,

    Why do I think that attachments cannot be imported at all?

    I am using ver 1.94 and the ImpExDatabase_400.php

    At first I was getting Attachment not imported fails for every single attachment there is in phpbb files folder.
    Then I saw "attach file 2" just before "Failed :: Attachment not imported" and I dig around the code to see where this comes from. Then first problem came to surface..

    Code:
    echo "attach file " . intval($attachfile);
    switch (intval($attachfile))
    .
    .
    .
    case '2':       // file system NEW naming schema
    This switch never works and always goes to default: which should never happen.

    My system has .. php 5.2.11 but don't have time to search for that so I removed the whole switch() and replaced it with in if (intval($attachfile)==0) ... etc to bypass this issue.. and it worked..

    BUT

    Now I am getting a mysql error which is very obvious and true.. filesize field does not exist in vb_attachment in vb4.0.0pl1

    I stopped here and before I go further figuring out what needs to be done I wrote this post to clarify that impex 1.94 indeed lacks attachment imports to vb4.

    Is this the case? and if it is should I go back to vb3.8.4pl1 do the whole import from phpBB3 and then upgrade to vb4? I realy do not wish to do that to be totally honest.

    By the way impex really rocks! Everything else went smooth from step 1 to 9.

  • #2
    I did it and it worked OK. It was a while back so I cannot recall the fine detail but I don't remember it being a major problem to do ....

    Comment


    • #3
      You did it in VB4.0.0PL1 and impex 1.94? How back in time can this be?

      Comment


      • #4
        Hmmm. Since there's no response to this problem i'm going to try to Impex phpbb -> vb3.8 then upgrade to 4.0.

        A bit silly but i have to get it done.

        Comment


        • #5
          That's what I did... it works.. no avatars but it works..

          Comment


          • #6
            Just to be clear, if I install 3.8, then import phpbb3 using IMPEX it will work bringing in the the attachments ???? and finishing everything off just fine ????

            I have tried several times to import phpbb3 into VB 4 and everything runs fine until I get to attachments and it will not do it.

            Comment


            • #7
              Yes. Just run impex and import your phpbb3 on lastest VB3.8. Everything is fine. Then upgrade to v4.0.1. My only problem is some duplicate users (user and imported_user which I deleted) and the user avatars. Everything else including attachments imported correctly.

              Comment


              • #8
                I also have the same issue, though with phpBB2. I just purchased Vb 4 however and have never ran 3.x, so installing 3.x only to upgrade to 4.0 seems like a ton of work.

                Was there a method posted that will definitely make the attachment import script work for phpBB2 -> VB4?

                Comment


                • #9
                  Found a semi-solution, I realized because I had the option for storing attachments in the filesystem instead of database enabled, this occurred.

                  I set it back to the database and it says they imported fine - however I don't see them on threads with attachments. The files are in the DB though.

                  Now my DB is over its storage limit and I'm trying to switch it back to filesystem and I get this error:

                  Fatal error: Out of memory (allocated 5767168) (tried to allocate 238782 bytes) in /homepages/xx/dxxxxxxxxx/htdocs/forum/includes/class_core.php on line 2277

                  Comment


                  • #10
                    Okay, I should really keep playing around before I post something here. By setting the number to process per page to 25 instead of 300, now it works. Problem is, the attachments are there, or at least it says it is... but they aren't in the posts.

                    Comment


                    • #11
                      After several more attempts I still cannot work out the correct path for attachments. This may be simple stuff to you wizz kids but to an ordinary bloke I am finding it most frustrating. The import goes ever so well up until attachments.
                      Can some compassionate soul please give me a sample path.
                      My phpbb3 data base and the new VB data base are on the same server, surely there is somebody out there who can tell me..........

                      Comment


                      • #12
                        hi, i've the same problem, i'm trying to import attachments from phpbb3 to vb4 but impex misses every file as you can see from the screenshot

                        Click image for larger version

Name:	Schermata 2010-01-18 a 14.37.42.jpg
Views:	1
Size:	29.2 KB
ID:	3677725

                        usually attachments in phpbb are accessed with this kind of address www.***.com/forum/download/file.php?id=3022 but i've no idea of how to set option "Full path to uploads/attachments folder where the source attachments are." in impex.

                        any suggestion?

                        Comment


                        • #13
                          I just cannot understand why I cannot get a simple answer that will make my system work from the people who gladly took my $300.00 US for a licence. It is getting just a little frustrating. I have been trying to do this for over a month , countless deletes and download again, then upload again, and all I need is some person who is supposed to know to give the info I need.
                          Is that too much to ask ?

                          Comment


                          • #14
                            Well, did you open a Trouble Ticket? It comes that when you post it here you expect to find help from the community but you still have the option to open a ticket and support will help you on that. I am not sure if support covers impex though. I don't see why not.

                            Comment


                            • #15
                              I am having very similar problems and getting NOWHERE on the forums, and I've put in a few tickets too.

                              I'm importing from phpbb 2 to vb 4.0.1. Like everybody is saying, the import goes smooth up until the attachments.

                              I'm choosing to store my attachments in a file system. I'm pointing to my correct original attachment source which is /var/www/vhosts/bogley.com/httpdocs/forum/files and I'm getting the error message of:
                              Failed :: Attachment not importedattach file 2

                              So ysam, I understand that you're coming from phpbb 3, but do you think I can make that same edit you did to ImpExDatabase_400.php and make some progress?

                              Sorry, I'm a noob at php stuff. Thanks for the help, there's been some good info in this thread so far.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X