No announcement yet.

Using IMPEX to import phpBB3 to vB4

  • Filter
  • Time
  • Show
Clear All
new posts

  • Using IMPEX to import phpBB3 to vB4

    Installed VB4...went really well.
    Using IMPEX, it goes really well until I get to import attachments.
    I just cannot work out how to find the correct path for the import to be successful.
    I have no knowledge of how to work in Linux and the like.
    Before the release of vB 4 I tried several practice IMPEX sessions and all went very well except for the attachments.
    I filed a support ticket and was told to telnet or SSH to find the exact path for the import.

    I simply have no idea how to do this.

    Can somebody please explain in simple terms how to find this last piece of missing info.

  • #2
    impex doesnt work with 4.0 yet, specifically attachments, new version should be out soon, i am waiting for it as well for phpbb
    Maxum Boat Forum / Computer Repair Cary NC


    • #3
      Thanks jhabers for your reply.
      In downloading the v4 suite IMPEX comes with it in the upload file, is that not the correct IMPEX ? I found it to work very well except for the attachment problem.


      • #4
        Hmm, just saw 4.0.0 PL1 is out, also noticed that Impex got updated to 1.94, wonder if it officially supports 4.0? ( I guess we will wait to hear.

        When doing your attachments telnet or ssh into the attachments directory in your phpbb install, the type pwd , copy that path to the impex. I will give it a try tomm. If you try before post back here and let me know if it worked, if not I guess we will just wait to get official word.

        * A read me
        * @package ImpEx
        * @author Jerry Hutchings <[email protected]>
        * @version $Revision: 2257 $
        * @date $Date: 2009-12-21 17:55:35 -0600 (Mon, 21 Dec 2009) $

        This ImpEx build version is :

        For a HOWTO go here:
        For a Manual go here :
        * End page
        Maxum Boat Forum / Computer Repair Cary NC


        • #5
          Thanks again jhabers,
          I just ran IMPEX again and it appears to run flawlessly except to when I get to importing attachments.
          I just do not know how to telnet or to ssh

          I use a ftp upload named CoreFTP which has an option for ssh, but I have tried all sorts of settings to no avail.


          • #6
            How exactly are you running ImpEx with 4.0, did you select 4.0 as the target version? Doing that makes a php error for me as there is a missing file (I looked at the download and the uploaded files and was missing on both, so it didn't get lost along the way).
            I'll go ahead and download ImpEx again just to see, but how you managed to get it to work is most interesting to me!
            Here is what I get after trying it again:
            PHP Code:
            Warning: require_once([path]/impex/ImpExDatabase_400.php) [function.require-once]: failed to open streamNo such file or directory in [path]/impex/index.php on line 190

            Fatal error
            : require_once() [function.require]: Failed opening required '/home2/mmootaku/public_html/forum/impex/ImpExDatabase_400.php' (include_path='.:/usr/lib/php:/usr/local/lib/php'in /home2/mmootaku/public_html/forum/impex/index.php on line 190 
            Last edited by Katsu4649; Tue 22nd Dec '09, 10:41pm.


            • #7
              Hi Katsu,
              I just did a clean upload of vB 4. (takes forever because there are 3,300 files approx )
              IMPEX is already in the "upload" file.
              I just did the adjustments to the config.php file adding the details of both DB's and it worked just fine........except when it gets to import attachments. There the message is, cant find the specified images.


              • #8
                Is there somebody out there who can tell me how to find the correct path for the attachments please ?


                • #10
                  Originally posted by MURRAY View Post
                  Is there somebody out there who can tell me how to find the correct path for the attachments please ?

                  Hey murray, log into your control panel for your host and see if you can find your ssh login information, then download "putty" (its a ssh client), log in then go to your attach directory then type "pwd" to get the full path

                  Maxum Boat Forum / Computer Repair Cary NC


                  • #11
                    also make sure your impex version is 1.94
                    Maxum Boat Forum / Computer Repair Cary NC


                    • #12
                      Has there been any update on this? I have the error looking for 400.php and cannot find any download of impex or vbulletin 4.0 that has it.


                      • #13
                        I'm thinking we may not see a reponse to this until after Christmas
               vb 4.1.10


                        • #14
                          I hope someone comes back with a fix for my problem soon. There must be some simple fix surely, the rest of the system works so well.


                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.