Announcement

Collapse
No announcement yet.

Import stops without an error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wynand
    replied
    I re-ran the whole thing with a 2 posts per cycle interval and left it running for the night and found the two precisers posts which I deleted (although they were no different that other posts). The import has gotten past them now, although it's still going at two posts per cycle.

    Leave a comment:


  • Wynand
    replied
    Is there any way to force a continue of the next row of 100 posts?

    Leave a comment:


  • Steve Machol
    replied
    Sorry, that is my only suggestion. I still think there is something wrong with the data for those posts.

    Leave a comment:


  • Wynand
    replied
    Code:
    CREATE TABLE IF NOT EXISTS `impexerror` (
      `errorid` bigint(20) unsigned NOT NULL auto_increment,
      `errortype` varchar(10) collate latin1_general_ci NOT NULL default '',
      `classnumber` varchar(3) collate latin1_general_ci NOT NULL default '',
      `importid` bigint(20) NOT NULL default '0',
      `error` varchar(250) collate latin1_general_ci default 'NULL',
      `remedy` varchar(250) collate latin1_general_ci default 'NULL',
      PRIMARY KEY  (`errorid`)
    ) ENGINE=MyISAM  DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci AUTO_INCREMENT=460 ;
    
    --
    -- Dumping data for table `impexerror`
    --
    
    INSERT INTO `impexerror` (`errorid`, `errortype`, `classnumber`, `importid`, `error`, `remedy`) VALUES
    (1, 'invalid', '006', 90, 'Invalid, skipping. Failed on : ', 'forumid'),
    (2, 'invalid', '006', 159, 'Invalid, skipping. Failed on : ', 'forumid'),
    (3, 'invalid', '006', 228, 'Invalid, skipping. Failed on : ', 'forumid'),
    .....
    (458, 'invalid', '007', 133695, 'Invalid, skipping. Failed on : ', 'threadid'),
    (459, 'invalid', '007', 133830, 'Invalid, skipping. Failed on : ', 'threadid');
    But, those are mostly for threads, not for posts.

    Leave a comment:


  • Steve Machol
    replied
    Then my guess is that you have something wrong with the data for the posts in that range.

    To log errors edit ImpExConfig.php and set the following to true:

    define('impexdebug', true);


    Then go to your vbulletin database, check the table impexerror.

    Leave a comment:


  • Wynand
    replied
    Doesn't appear so, I put the timeout to 6000 and cycle to 100, freezes at "From : 155665 :: To : 157665", clicking the "import" button again in the ACP leads to the same page (direct load, so probably no processing).

    Leave a comment:


  • Steve Machol
    replied
    The posts issue may also be from timing out. Try is again with the larger setting and/or running a smaller batch.

    Leave a comment:


  • Wynand
    replied
    Looking at the type of server I'm dealing with here (it's a colocated server for the record), that suprises me a little. I put the wait_timeout to 120 (was at 45) and started it with 100 users per cycle, seems to keep going now. Any suggestions for the posts part?

    Leave a comment:


  • Steve Machol
    replied
    This is a server issue. You'll need to contact your host about this. Here are the reasons for the MySQL server going away:

    http://www.vbulletin.com/forum/showt...265#post310265

    Also from the MySQL site:

    http://dev.mysql.com/doc/refman/5.0/en/gone-away.html

    Leave a comment:


  • Wynand
    replied
    Originally posted by Steve Machol View Post
    Try repairing the IPB database to see if that helps.

    Impex for vB4 will not be available until sometime after the Gold release. I do not have specific timing. Impex has never been supported to take the place of a regular upgrade.
    I already ran a repair (IPB building + phpmyadmin) on all tables in that database, but that didn't seem to help. Any other suggestions on that one?
    There's no direct need for it, as long as importing -> vB 3.8.4 -> upgrade to vB 4 goes fine.

    An other question is, when I chose "Would you like to import the avatars, this can take some time if they are remotely linked" - yes, remote linked, I assume that is when a user for example uses tinypic to host their avatar. What is the need for the complete avatarpath there? (currently, avatar uploading to our own server is disabled)
    When I go with it without a path, it spits this out:

    ImpEx Database errormysql error: Invalid SQL: DESCRIBE userfield field2

    mysql error: MySQL server has gone away

    mysql error number: 2006

    Date: Sunday 06th 2009f December 2009 05:09:32 PM
    Database: *****
    MySQL error:

    Leave a comment:


  • Steve Machol
    replied
    Try repairing the IPB database to see if that helps.

    Impex for vB4 will not be available until sometime after the Gold release. I do not have specific timing. Impex has never been supported to take the place of a regular upgrade.

    Leave a comment:


  • Wynand
    started a topic Import stops without an error

    Import stops without an error

    - Clean import
    - Source: IPB 2.3.8
    - Target: vB 3.8.4 PL1
    - Module issue: posts import

    No errors of any kind, but the processes just stops (no, it's not a login timeout). Roughly 300k posts should be imported, it's stops about halfway at 158712 :: To : 158812. Changing the amount of posts to import at a time does not seem to matter, and it stops without an error.
    Any suggestions how how to debug this?

    And while I'm at it anyway, how soon after the release of vB 4 can we expect an updated impex version? An import to 3.8.4 + upgrade to 4 is possible, but an impex version that supports vB 4 as well would be good to have as well.
    Last edited by Wynand; Sat 5 Dec '09, 12:18pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X