Announcement

Collapse
No announcement yet.

Migrating SMF -> VB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Migrating SMF -> VB

    Hello,

    I've just purchased a vBulletin license (though have been using the software for years) and am attempting to migrate a dev copy of an smf forum (30k posts, 400 members) to vBulletin 4. I realise it is still in Beta, which is why I'm currently working in Dev and will wait for the Gold release before going live. I plan is to work on importing and theming vBulletin Beta 4, and then integrating it with wordpress and a wiki as a proof of concept while waiting for the Gold to be released.

    After some research it seems that ImpEx doesn't support vb 4 as yet, so I installed the latest vb3.x and am in the process of importing smf into that. Once this import is successful I will upgrade to the latest beta.

    I've successfully imported users, usergroups, forums and threads, however have noticed failures on PMs (1150 success / 9 fail), attachments (59 / 184), post (31799 / 754), polls (22 / 13), smilies (69 / 1), and 59 / 184). Is there a log or something that will give me further infromation on the failures?

    Additionally, 0 avatars have been imported. My smf forum stores the avatars in the same folder as the attachments, that folder is on the same server as my dev installation and I have retrieved the path via a 'pwd' and chmod 775 (tried 777 too).

    Thanks for any advice you can provide,
    Moses
    sigpic

  • #2
    In the ImpExConfig.php, set the following to true

    define('impexdebug', true);

    - go to your vbulletin database, check the table imprexerror
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks for that Steve,

      Would I be advised to upgrade smf forum from 1.1.8 to 2.x before the import?

      Edit: found the table, it's actually impexerror, and since I've got a table prefix it's vb_impexerror
      Last edited by oz_moses; Sun 29 Nov '09, 7:15pm.
      sigpic

      Comment


      • #4
        I've restarted the migration from scratch with the debug and errorlogging = true. I still receive errors as above with attachments and avatars, however upon checking the vb_impexerror table it is empty. Am I missing something?
        sigpic

        Comment


        • #5
          That is the only option to track errors. At this point I would report this as an Impex bug.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Can someone confirm that importing avatars from smf to vbulletin with impex does actually work?

            I've looked at several boards who have migrated from smf, none appear to have avatars coming through.
            sigpic

            Comment


            • #7
              Avatars are not listed as one of the items that are imported.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                Avatars are not listed as one of the items that are imported.
                Thanks for the answer Steve, I guess I'll manually bring through avatars, there's not a huge amount of users so that's doable. I suppose I was getting thrown by the option "Would you like to import the avatars, this can take some time if they are remotely linked". I've also got issues with thread icons not coming through but looks like they don't get imported either.

                I can live with these though, my big trouble at the moment is with BBCODE, things like

                [quote author=Noddy link=topic=8954.msg55429#msg55429 date=1259894805]
                stripes are very thinning.
                [/quote]

                are not rendering. I'm considering doing an update against the post table to change every occurrence of "quote" to "smfquote" then build a custom BBCode that brings in the author name, just doens't link back to the original post. Does this approach sound like it'll work?
                sigpic

                Comment


                • #9
                  so I take it there is no work around to import posts with quotes in them?
                  sigpic

                  Comment


                  • #10
                    Those are not imported correctly. You will need to modify them manually. Sorry.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X