Announcement

Collapse
No announcement yet.

Import failed : problem with table prefix?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import failed : problem with table prefix?

    I'm trying to transfer phpbb3 to VB. Its saying to me:

    If you have all red tables, i.e. none correct this could possible be your table prefix :

    phpbb_
    Failed Check database permissions and connection, or table prefix to ensure its correct

    Does anybody know what this means? I didn't think I had a prefix. I checked my config file and couldn't find one

  • #2
    This is what I get:

    Altering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers. This is needed during the import process for maintaining references between the tables during an import. If you have large tables (i.e. lots of posts) this can take some time. They will also be left after the import if you need to link back to the original vB userid.
    moderator - importmoderatorid Completed
    usergroup - importusergroupid Completed
    ranks - importrankid Completed
    poll - importpollid Completed
    forum - importforumid Completed
    forum - importcategoryid Completed
    user - importuserid Completed
    style - importstyleid Completed
    thread - importthreadid Completed
    post - importthreadid Completed
    thread - importforumid Completed
    smilie - importsmilieid Completed
    pmtext - importpmid Completed
    avatar - importavatarid Completed
    customavatar - importcustomavatarid Completed
    customprofilepic - importcustomprofilepicid Completed
    post - importpostid Completed
    attachment - importattachmentid Completed
    pm - importpmid Completed
    usernote - importusernoteid Completed
    phrase - importphraseid Completed
    subscription - importsubscriptionid Completed
    subscriptionlog - importsubscriptionlogid CompletedTesting source against : ::3.0.3


    Valid found tables :


    Possibly custom tables or incorrect prefix :

    acl_groups NOT found.
    acl_options NOT found.
    acl_roles NOT found.
    acl_roles_data NOT found.
    acl_users NOT found.
    attachments NOT found.
    banlist NOT found.
    bbcodes NOT found.
    bookmarks NOT found.
    bots NOT found.
    config NOT found.
    confirm NOT found.
    disallow NOT found.
    drafts NOT found.
    extension_groups NOT found.
    extensions NOT found.
    forums NOT found.
    forums_access NOT found.
    forums_track NOT found.
    forums_watch NOT found.
    groups NOT found.
    icons NOT found.
    lang NOT found.
    log NOT found.
    moderator_cache NOT found.
    modules NOT found.
    poll_options NOT found.
    poll_votes NOT found.
    posts NOT found.
    privmsgs NOT found.
    privmsgs_folder NOT found.
    privmsgs_rules NOT found.
    privmsgs_to NOT found.
    profile_fields NOT found.
    profile_fields_data NOT found.
    profile_fields_lang NOT found.
    profile_lang NOT found.
    ranks NOT found.
    reports NOT found.
    reports_reasons NOT found.
    search_results NOT found.
    search_wordlist NOT found.
    search_wordmatch NOT found.
    sessions NOT found.
    sessions_keys NOT found.
    sitelist NOT found.
    smilies NOT found.
    styles NOT found.
    styles_imageset NOT found.
    styles_template NOT found.
    styles_template_data NOT found.
    styles_theme NOT found.
    topics NOT found.
    topics_posted NOT found.
    topics_track NOT found.
    topics_watch NOT found.
    user_group NOT found.
    users NOT found.
    warnings NOT found.
    words NOT found.
    zebra NOT found.

    Comment


    • #3
      Originally posted by 04wayne View Post
      phpbb_
      Failed Check database permissions and connection, or table prefix to ensure its correct

      Does anybody know what this means? I didn't think I had a prefix. I checked my config file and couldn't find one
      It means exactly what it says: Either you have not set the database credentials for your phpBB database correctly, or you have set a wrong prefix.

      You have to set this in the config.php file of impex. See manual: http://www.vbulletin.com/docs/html/impex_config It goes along the same lines as editing the config.php of vB, which you already did. Only this time you net to set the phpBB db credentials into the impex config.

      The part you need to fill in:
      PHP Code:
      # If the system that is being imported from uses a database, 
      # enter the details for it here and set 'sourceexists' to TRUE. 
      # If the source data is NOT stored in a database, set 'sourceexists' to FALSE 

      $impexconfig['sourceexists']              = false

      # mysql / mssql 
      $impexconfig['source']['databasetype']    = 'mysql'
      $impexconfig['source']['server']          = 'localhost'
      $impexconfig['source']['user']            = 'username'
      $impexconfig['source']['password']        = 'password'
      $impexconfig['source']['database']        = 'source'
      $impexconfig['source']['tableprefix']     = ''
      What to insert exactly no one here can tell.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X