Announcement

Collapse
No announcement yet.

Impex Error on Check And Update Database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impex Error on Check And Update Database

    Hi;
    I am using impex 1.93.
    I want to import data
    to vBulletinĀ® Version 3.8.4
    from ASPPlayground.NET Forum Commercial Version 3.4

    When I loged Impex, I am seeing this error :
    Code:
    ImpEx Database errormysql error: Invalid SQL: 
         INSERT INTO vf_usergroup
         (
          importusergroupid, title, description,
          usertitle, passwordexpires, passwordhistory,
          pmquota, pmsendmax,
          opentag, closetag, canoverride,
          ispublicgroup, forumpermissions, pmpermissions,
          calendarpermissions, wolpermissions, adminpermissions,
          genericpermissions, genericoptions, attachlimit,
          avatarmaxwidth, avatarmaxheight, avatarmaxsize,
          profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize,
          signaturepermissions, sigpicmaxwidth, sigpicmaxheight,
          sigpicmaxsize, sigmaximages, sigmaxsizebbcode, sigmaxchars,
          sigmaxrawchars, sigmaxlines
         )
         VALUES
         (
          '69',
          'imported_users',
          'Usergroup description',
          '',
          0,
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          ''
         )
     
    mysql error: Incorrect integer value: '' for column 'passwordhistory' at row 1
    mysql error number: 1366
    Date: Tuesday 27th 2009f October 2009 11:13:45 PM
    Database: vforum
    MySQL error:
    Why The Impex trying insert a string value to an integer field ?
    I am thinking "the problem is in the ImpExDatabaseCore.php"
    I changed line 3190 in ImpExDatabaseCore.php
    Original Line : ['" . $this->get_value('nonmandatory', 'passwordhistory') . "',]
    New Line : [-0,]

    The Error changed to about pmquota, now.

    Is this a bug ?
    Please help me ...
    http://www.yabantv.com

  • #2
    Were you able to resolve this?

    Comment


    • #3
      I solved this issue

      I changed
      define('forcesqlmode', false); value to
      define('forcesqlmode', true);

      It is working now, All other problems about my php version. 5.3.x series generating error, because mssql lib changed to sqlsrv.
      http://www.yabantv.com

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X