Announcement

Collapse
No announcement yet.

Random 404 error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random 404 error

    I was in the middle of importing my new database and about half way down the modules my impex suddenly started giving me a 404 error?

    The rest of admincp works fine but it's just impex. I'm not sure what happend.

    I was importing a phpbb3 db if that means anything.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Last edited by jkun; Mon 10 Aug '09, 5:42am.

  • #2
    Which import module were you on when this happened?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I can't remember exactly but it was the next module after users.

      Comment


      • #4
        Clear out the imported session and data and try again. Then if it happens again please state which module this was.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Clear out the imported session and data and try again. Then if it happens again please state which module this was.
          I'm not sure how to do this. I can't get into impex at all.

          Comment


          • #6
            You can run '.../impex/help.php' directly in your browser to do that.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thanks.

              It seems the error is caused during 'Import post'.

              Comment


              • #8
                This may be a server time and/or memory limit. To increase your limits edit your includes/config.php file and add these lines right under the <?php line:

                ini_set('memory_limit', -1);
                ini_set("max_execution_time", "2880");

                Then use a smaller batch number for import posts and try again.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I edited the config file and tried with half the number and the error happened again.

                  Comment


                  • #10
                    Please make sure that all Impex files are uploaded and that the permissions for the directories are set to 755 and the files to 644.

                    Then if you still have this problem this may be due to mod_security. Please see this thread for the fix:

                    http://www.vbulletin.com/go/modsecurity
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      All the permissions are correct and i've done the suggestion from the thread you linked.

                      It's importing the first 575 posts but after that it brings up the error again.

                      Comment


                      • #12
                        The next step is to ask your host to check the server error logs. Something is causing this and that info should be in the logs.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          I just went through the error logs and there's nothing on there. Eeek.

                          Comment


                          • #14
                            Well the only possibilities are that there is either something wrong with the source data, or it's a server issue. Unfortunately I really don't have any other suggestions,

                            However in my experience. 'Internal Server Error' means exactly that - it is a server issue. And AFAIK servers should be logging all such errors. If they aren't then there is something wrong with how this server is set up.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Dramatically lower the number of post being imported per page on the next try.
                              I wrote ImpEx.

                              Blog | Me

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X