Announcement

Collapse
No announcement yet.

Import from phpBB3 not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import from phpBB3 not working

    Hi. I've been trying to import my phpBB3 over to vBulletin and I get the following error:

    ImpEx Database errormysql error: Invalid SQL: SHOW TABLES

    mysql error: No database selected

    mysql error number: 1046

    Date: Tuesday 17th 2009f March 2009 12:54:12 AM
    Database: kris_fphpbb
    MySQL error: No database selected


    My databases are on the same server and this is the setting of my Impexconfig file:

    Code:
    <?php
    if (!defined('IDIR')) { die; }
    
    #################################################################### |;
    # vBulletin  - Licence Number VBF8CCD460
    # ---------------------------------------------------------------- # |;
    # Copyright ©2000–2009 Jelsoft Enterprises Ltd. All Rights Reserved. |;
    # This file may not be redistributed in whole or significant part. # |;
    # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # |;
    # http://www.vbulletin.com | http://www.vbulletin.com/license.html # |;
    #################################################################### |;
    
    # The following settings allow ImpEx to connect to the vBulletin 3
    # database into which you will be importing data.
    
    ####
    #
    # TARGET - The target is the vBulletin database (where the  data is going to)
    #
    ####
    
    $impexconfig['target']['server']        = 'localhost';
    $impexconfig['target']['user']            = 'kris_user';
    $impexconfig['target']['password']        = 'password';
    $impexconfig['target']['database']        = 'kris_vb2009';
    $impexconfig['target']['tableprefix']    = '';
    
    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to true.
    # If the source data is NOT stored in a database, set 'sourceexists' to false
    
    $impexconfig['sourceexists']            = true;
    
    ####
    #
    # SOURCE - The source is the old forum database (where the  data is coming from)
    #
    ####
    
    # mysql / mssql
    $impexconfig['source']['databasetype']    = 'mysql';  // mysql OR mssql
    $impexconfig['source']['server']        = 'localhost';
    $impexconfig['source']['user']            = 'kris_user';
    $impexconfig['source']['password']        = 'password';
    $impexconfig['source']['database']        = 'kris_fphpbb';
    $impexconfig['source']['tableprefix']   = 'phpbb_';
    
    ####
    #
    # DUPLICATE CHECKING
    # Where unique import id's are available ImpEx can check for duplicates with some
    # Tier2 systems this will need to be set to false.
    #
    # yahoo_groups, YaBB 2.1, Ikonboard 3.1.5 (for attachments)
    #
    ####
    
    define('dupe_checking', false);
    
    ###############################################################################
    ####
    #
    # ADVANCED - For a standard import or a novice user leave the settings below.
    #
    ####
    
    // Advanced Target
    $impexconfig['target']['databasetype']    = 'mysql';    // currently mysql only
    $impexconfig['target']['charset']        = '';
    $impexconfig['target']['persistent']    = false;     // (true/false) use mysql_pconnect
    
    // Advanced Source
    $impexconfig['source']['charset']        = '';
    $impexconfig['source']['persistent']    = false;
    
    # pagespeed is the second(s) wait before the page refreshes.
    
    $impexconfig['system']['language']        = '/impex_language.php';
    $impexconfig['system']['pagespeed']        = 1;
    
    $impexconfig['system']['errorlogging']    = false;
    
    define('impexdebug', false);
    define('emailcasesensitive', false);
    define('forcesqlmode', false);
    define('skipparentids', false);
    define('shortoutput', false);
    define('do_mysql_fetch_assoc', false);
    define('step_through', false);
    define('lowercase_table_names', false);
    define('use_utf8_encode', false);
    define('use_utf8_decode', true);
    ?>

  • #2
    That means that database does not exist on this server. Fill out a support ticket at:

    http://members.vbulletin.com/members...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I was able to fix this and I thought I'd share my fix...I checked and double and triple checked that I as using the right database/user/passwords...and then discovered that when I transferred my files over to my new host, my user/password combinatio was different. I added the right user/password to my database, re-ran it and that part of the transfer worked.

      Comment


      • #4
        Glad to here it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X