Announcement

Collapse
No announcement yet.

Impex for phpbb 3.0.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Please follow the 'After the Import' instructions here:

    http://www.vbulletin.com/docs/html/impex_cleanup

    Then if you need further assistance please start your own thread with all the relevant details.

    Leave a comment:


  • arimislacker
    replied
    Originally posted by Jerry View Post
    What version of ImpEx was that with ?
    I'm having the exact same issue as the OP. Members, PMs, Groups all imported successfully. Threads dont seem to be there.

    ImpEx build version : 1.92
    phpBB 3.0.4
    vBulletinĀ® Version 3.8.1

    Leave a comment:


  • pushtiulk
    replied
    i fix it. i forgot to put the table prefix for phpbb database.

    Leave a comment:


  • pushtiulk
    replied
    i've installed vbulletin 3.8.1 on localhost, i've created 2 databases (1 for vbulletin and 1 for phpbb 3.0.4) and i've tried to import phpbb db to vbulletin. and from the first module i'm receive this error:

    Altering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers. This is needed during the import process for maintaining references between the tables during an import. If you have large tables (i.e. lots of posts) this can take some time. They will also be left after the import if you need to link back to the original vB userid.
    moderator - importmoderatorid Completed
    usergroup - importusergroupid Completed
    ranks - importrankid Completed
    poll - importpollid Completed
    forum - importforumid Completed
    forum - importcategoryid Completed
    user - importuserid Completed
    style - importstyleid Completed
    thread - importthreadid Completed
    post - importthreadid Completed
    thread - importforumid Completed
    smilie - importsmilieid Completed
    pmtext - importpmid Completed
    avatar - importavatarid Completed
    customavatar - importcustomavatarid Completed
    customprofilepic - importcustomprofilepicid Completed
    post - importpostid Completed
    attachment - importattachmentid Completed
    pm - importpmid Completed
    usernote - importusernoteid Completed
    phrase - importphraseid Completed
    subscription - importsubscriptionid Completed
    subscriptionlog - importsubscriptionlogid Completed

    Valid found tables :


    Possibly custom tables or incorrect prefix :

    acl_groups NOT found.
    acl_options NOT found.
    acl_roles NOT found.
    acl_roles_data NOT found.
    acl_users NOT found.
    attachments NOT found.
    banlist NOT found.
    bbcodes NOT found.
    bookmarks NOT found.
    bots NOT found.
    config NOT found.
    confirm NOT found.
    disallow NOT found.
    drafts NOT found.
    extension_groups NOT found.
    extensions NOT found.
    forums NOT found.
    forums_access NOT found.
    forums_track NOT found.
    forums_watch NOT found.
    groups NOT found.
    icons NOT found.
    lang NOT found.
    log NOT found.
    moderator_cache NOT found.
    modules NOT found.
    poll_options NOT found.
    poll_votes NOT found.
    posts NOT found.
    privmsgs NOT found.
    privmsgs_folder NOT found.
    privmsgs_rules NOT found.
    privmsgs_to NOT found.
    profile_fields NOT found.
    profile_fields_data NOT found.
    profile_fields_lang NOT found.
    profile_lang NOT found.
    ranks NOT found.
    reports NOT found.
    reports_reasons NOT found.
    search_results NOT found.
    search_wordlist NOT found.
    search_wordmatch NOT found.
    sessions NOT found.
    sessions_keys NOT found.
    sitelist NOT found.
    smilies NOT found.
    styles NOT found.
    styles_imageset NOT found.
    styles_template NOT found.
    styles_template_data NOT found.
    styles_theme NOT found.
    topics NOT found.
    topics_posted NOT found.
    topics_track NOT found.
    topics_watch NOT found.
    user_group NOT found.
    users NOT found.
    warnings NOT found.
    words NOT found.
    zebra NOT found.


    If you have all red tables, i.e. none correct this could possible be your table prefix :

    phpbb_
    Failed Check database permissions and connection, or table prefix to ensure its correct

    what should i do so i can import the phpbb 3.0.4 db in vbulletin 3.8.1?

    thanks

    Leave a comment:


  • Jerry
    replied
    Originally posted by Cybermonsters View Post
    After importing posts I would import private messages, but then all the posts disappeared. Did this twice with same outcome. There was no error message, they just disappeared..
    What version of ImpEx was that with ?

    Leave a comment:


  • Cybermonsters
    replied
    Maybe this will help others with a similiar situation.

    3.0.4 phpbb with 160,000 posts imported via Impex to 3.8.1

    After importing posts I would import private messages, but then all the posts disappeared. Did this twice with same outcome. There was no error message, they just disappeared.

    So I just imported posts and skipped importing PM's and it worked fine.

    *Note* I've read that Phpbb 3.x imports will not import member passwords. Members have to be emailed to reset passwords. That's a character of Phpbb 3.x, not impex. For that reason I am going to transfer all my phpbb 2.x boards to VB instead of updating to phpbb 3.x, so I don't have to go through that mess with members.

    Leave a comment:


  • Jerry
    replied
    Yes, that version is supported.

    What is the reported error from ImpEx during the import ?

    Leave a comment:


  • Cybermonsters
    started a topic Impex for phpbb 3.0.4

    Impex for phpbb 3.0.4

    Does Impex work for phpbb 3.0.4?
    It's not importing threads. I've done several phpbb 2.x impex imports with no problems.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X