Announcement

Collapse
No announcement yet.

Problem mysql error: Unknown column 'product' in 'where clause'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem mysql error: Unknown column 'product' in 'where clause'

    Hi,
    I'm using Vbulletin 3.7.2.
    I'm getting the following error when trying to do an import:


    ImpEx Database errormysql error: Invalid SQL:
    SELECT fieldname, vbmandatory, defaultvalue, dictionary
    FROM vbfields
    WHERE tablename = 'usergroup'
    AND product='vbulletin'
    ORDER BY vbmandatory


    mysql error: Unknown column 'product' in 'where clause'

    mysql error number: 1054

    Date: Thursday 07th 2008f August 2008 11:55:06 AM
    Database: db219539753
    MySQL error:
    I checked the target database table vbfields and there is really no column
    "product".

    What is wrong here?
    Why is this field missing in my vbulletin installation? Maybe it was missing in any update scripts?

    Please help, i need to get the new board up asap!

    Thank ou and regards
    mlee

  • #2
    Forgot to mention
    ImpEx build version : 1.90

    Comment


    • #3
      Clear out the import data and session, and drop the vbfields table. Then try again.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Hi, okay just for the record if anyone else has the same problem.

        I deleted all as you sayed and after creation i had the same problem.

        I then created the table manually with the query i got from the impex file, and restarted the import all worked fine, this way.

        I guess he had some problems with writing temporary sql data to the tmp dir under windows.

        Regards mlee

        Comment


        • #5
          I believe this may be a bug. I just had the exact same issues apply to my Linux system (vBullterin 3.7.4 to vBulletin 3.7.4 import, ImpEx 1.92, CentOS 5.2).

          I had to manually delete vbfields, clear the session, and manually recreate vbfields. Everything is now working perfectly.

          Comment


          • #6
            I am having the same problem trying to import vb 3.7.4 to vb 3.8.4 !
            I then upgraded the old one (so both now are vb 3.8.4) but I got the same problem, please help ?

            You delete vbfields table ? from which database (target or source) ?

            Thanks,,
            http://www.al-jarodiah.com/vb/
            Arabic Village Social forums

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X