Announcement

Collapse
No announcement yet.

Can't import YaBB 2.1 - posts keep failing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't import YaBB 2.1 - posts keep failing

    i can't get yabb 2.1 imported--everything works up until i try to import posts.

    when i start importing the posts, the same page keeps refreshing over and over again, but the contents of the page do not change.

    i have tried doing the import on 2 different servers and found the same results. i am running php 4.4.8 and mysql 4.1.22-standard on both servers
    i have also tried increasing php memory on the server from 8M to 32M, and i still have the page refreshing over and over with the same contents.

    i tried using xammp to do am import on my local machine. when i use php 4 i get the same results as above. when i use php 5, the post imports work at first, but eventual fail at the same spot everytime with this error:

    81.25% :: post -> Re: Multiple Matches!
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 16069739 bytes) in G:\xa\xampp\htdocs\testlpf\impex\ImpExFunction.php on line 180

    i have tried increasing php memory usage to 80M, 128M, 256M, 512M, and it still fails at this point everytime. i have tried only doing 25 posts at a time, and even 10 at a time, and it still fails.


    should i try putting php5 on my server?

    i am stumped at this point on what to try next

    thanks for any help

  • #2
    Try leaving the memory limit as high as you can, and don't give impex a path for the attachments and see if it the page progresses.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      hi jerry,

      are you referring to the attachments directory that is asked for before importing posts? i assume you mean this one, and not the one in the first step for the 'uploads' folder in module 1.

      should i keep VB set up to not store attachments in the mysql database?

      thanks for your help

      regards,
      -avery

      Comment


      • #4
        I'd advise setting vBulletin to store the attachments in the file system before doing the import, and the path asked for during the post module.

        If you don't give it one, it will fail on the attachments during the post module, though will be a test to see if it's the memory that is an issue as it wont use as much.
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          hi jerry, i left it blank and it still kept refreshing the same page over and over
          this is on the remote server that i am doing the testing on. i think this confirms that it is not a memory issue on my server.

          on my local machine, i have made progress with xammp -- i believe it is working
          i had edited the wrong php.ini file (side note: dont know what the purpose of having 2 of them is its really confusing lol, they should fix that)

          ideally i would like to get this import to work on my remote server so i dont need to transfer as many files.

          there is one issue regarding the import on my local machine... yabb is on a linux forum, and the attachments folder has many files with the same file name but different case, e.g. File.jpg file.jpg.. there are lots of these types of files, and when i try to extract the attachments on my Windows machine, i have to overwrite the files and it just woln't work because windows is not case-sensitive in files


          so.. in conclusion, i really want to get this to work on the remote server b/c i don't know how to handle the file name issue, and it will be to much effort to reupload everything

          please let me know what additional information i can provide (if any) so we can get this working on my remote server. im assuming there must be some type of bug

          talk soon, thanks for your continued support.. you are the man

          Comment


          • #6
            Continued in support ticket.
            I wrote ImpEx.

            Blog | Me

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X