Announcement

Collapse
No announcement yet.

What do I do with phpbb_backup.sql?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thestaton
    replied
    Originally posted by Jerry View Post
    Was edit 3 the error you last had ?
    Yes, what I did to resolve the problem. I re-downloaded the database from the old phpbb2 board, and all was fine. I guess on the first download it got corrupted.

    I do appreciate the reply,

    Leave a comment:


  • Jerry
    replied
    Originally posted by thestaton View Post
    After about 3 hours of processing it came back with there is an error in my database...

    There has got to be an easier way.

    edit 3:

    ERROR 1064 (42000) at line 10427100: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''2847' at line 1
    Was edit 3 the error you last had ?

    Leave a comment:


  • Steve Machol
    replied
    Unfortunately there is not much we can do about this. My guess is that the backup was made with a different version of MySQL than is running on the server you are restoring it to. If you can somehow match those versions this may fix that problem.

    Leave a comment:


  • thestaton
    started a topic What do I do with phpbb_backup.sql?

    What do I do with phpbb_backup.sql?

    I have downloaded the backup for the older phpbb forum and uploaded it to the new server.

    Right now I have it sitting in the forums root directory.

    What do I need to do with the backup sql file?

    Do I need to create a new SQL DB, then import this DB into it? If so do you use phpmyadmin? Steps on how to do this?

    It's 1.2 gigs...

    Or can I link the installer to just this file?

    Thanks,

    edit:

    I used the command line and manually got mysql to start importing the DB.

    then I got this error...

    ERROR 1062 (23000) at line 2728104: Duplicate entry 'murci?lago' for key 1

    Would this have something to with the character setting on import?

    Any ideas on how to fix this?

    edit 2:

    using the command line:
    mysql -u forum -p -f --default_character_set utf8 forum_phpbb < phpbb.sql

    I can get it to start extracting. Now with the -f I have gotten rid of the duplicate entry errors. After about 3 hours of processing it came back with there is an error in my database...

    There has got to be an easier way.

    edit 3:

    ERROR 1064 (42000) at line 10427100: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''2847' at line 1
    Last edited by thestaton; Sat 24 May '08, 2:01pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X