Announcement

Collapse
No announcement yet.

Importing from SMF

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Importing from SMF

    I've purchased and installed VB flawlessly, but now I need to transfer from SMF.

    I've also downloaded and installed ImpEx and have modified my Impexconfig.php file and have checked, double checked, and tripple checked my server names, username, passwords, etc.... but I when I log in as aministrator and try to import my SMF data, I keep getting "Connection to source server failed. Check username and password."

    Then, in the center of the screen, I get "Database error in vBulletin 3.5.8:
    Invalid SQL:"

    ??????????? Any suggestions?


  • #2
    Invalid SQL errors are almost always related to modified code.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hm...

      When I add define('DISABLE_HOOKS', true); to config.php, then Impex stops working.

      I'm sure it has to be something simple. I'm just trying to import this forum: http://www.galaxy-marketing.com/sate...support-forum/

      Please help!!!

      Comment


      • #4
        Sorry, my bad. Remove that line and manually disable any non-vB add-ons. Then reupload your original vB and Impex files.

        Also make sure you are choosing the correct target vB version.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Same Problem

          Hi,

          I did that and it's still the same problem.

          Now I only get the message saying "Connection to source server failed. check username and password."

          What else do you think I can do?

          Any help would be greatly appreciated specially since I've been trying to get this done since Saturday night.

          Thanks

          Comment


          • #6
            What's the URL to your vB forums?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hi,

              Thank you so much for the reply.

              VB Forum: http://www.satellitestuff.net/forum/
              SMF Forum: http://www.galaxy-marketing.com/sate...support-forum/

              Comment


              • #8
                Originally posted by robbyd4182 View Post
                Now I only get the message saying "Connection to source server failed. check username and password."
                This means that the source db info you have in ImpExConfig.php is wrong, or you cannot connect to that server. If the SMF data is on a different server, then you will need to move it to the same server that vB is running on.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks for the help.

                  It's impossible to move it to the same server because GoDaddy assigns the server automatically to each individual database. I noticed it gives me Error Number 2013. If that helps...

                  I've been trying to do this for over a week now and realy do need to get it up and running. Is it possible to PM you the necessary information and maybe you can tell me what I may be doing wrong? Or if you have any other ideas of what I should do to get it going quickly, that would be great because I'm under time restrictions.

                  Thanks

                  Comment


                  • #10
                    I have never heard of that restriction on GoDaddy before an I've seen a lot of customers using them.

                    There are only two choices:

                    1. The databases need to be on the same server, or

                    2. GoDaddy will need to configure both servers to allow you to access remote MySQL connections.

                    The latter is very unlikely to happen.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Thank You ~ Thank You

                      Thanks. Got that taken care of and it connected.

                      I hope you can help me out with this also.

                      I got to the "start module" on "Check and update database", "Associate Users" and I was successful.

                      When I go to "start module" on "Import usergroup", I first get the following message:

                      ImpEx Database errormysql error: Invalid SQL:
                      INSERT INTO usergroup
                      (
                      importusergroupid, title, description,
                      usertitle, passwordexpires, passwordhistory,
                      pmquota, pmsendmax,
                      opentag, closetag, canoverride,
                      ispublicgroup, forumpermissions, pmpermissions,
                      calendarpermissions, wolpermissions, adminpermissions,
                      genericpermissions, genericoptions, attachlimit,
                      avatarmaxwidth, avatarmaxheight, avatarmaxsize,
                      profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize,
                      signaturepermissions, sigpicmaxwidth, sigpicmaxheight,
                      sigpicmaxsize, sigmaximages, sigmaxsizebbcode, sigmaxchars,
                      sigmaxrawchars, sigmaxlines
                      )
                      VALUES
                      (
                      '69',
                      'Imported Users',
                      'Usergroup description',
                      '',
                      0,
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      '',
                      ''
                      )

                      mysql error: Unknown column 'signaturepermissions' in 'field list'
                      mysql error number: 1054
                      Date: Sunday 13th 2008f April 2008 11:41:11 AM
                      Database: vbullteinforum1
                      MySQL error:

                      When I click continue, I get:

                      ImpEx Database errormysql error: Invalid SQL: SELECT * FROM smf_membergroups ORDER BY ID_GROUP LIMIT , 50
                      mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 50' at line 1
                      mysql error number: 1064
                      Date: Sunday 13th 2008f April 2008 11:41:14 AM
                      Database: robby41
                      MySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 50' at line 1


                      Any ideas on that? I realy appreciate your help.

                      Comment


                      • #12
                        signaturepermissions is a default 3.6.8 (and 3.7.0) field in the vBulletin database.

                        What does this SQL return :

                        Code:
                        describe usergroup
                        I wrote ImpEx.

                        Blog | Me

                        Comment


                        • #13
                          I got this error message: "You have to choose at least one column to display"

                          I ran it in both the source and target databases and same thing. I choose the field "usergroup.*" and the Use Table "usergroup"

                          I also tried to run it with out choosing any of the fields and still the same error message.

                          Is there something different I can run?

                          Comment


                          • #14
                            This is a fresh install of vBulletin using the latest version of impex ?

                            What version of MySQL are you running and on what OS ?
                            I wrote ImpEx.

                            Blog | Me

                            Comment


                            • #15
                              This is all new stuff. I'm running 3.5.8 on Linux & using mysql

                              Could not use the newest version because I don't think the server supports it.

                              http://www.satellitestuff.net/forum/

                              ? ? Any idea ? ?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X