Announcement

Collapse
No announcement yet.

e107 import hangs on 004 forum import @ 44.44%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • e107 import hangs on 004 forum import @ 44.44%

    Type of import = Clean

    Source board system and version = e107 0.7.8

    Target version = 3.6.8 Patch Level 2

    Module issue occurred on = 004 Import Forum

    Any SQL error reported = none

    Impex version = ImpEx build version : 1.87

    Description:
    001 completes. The following tables are missing; however the task completes successfully

    Possibly custom tables or incorrect prefix :
    e107_cache NOT found.
    e107_content NOT found.
    e107_event NOT found.
    e107_event_cat NOT found.
    e107_irc NOT found.
    e107_link_category NOT found.
    e107_parser NOT found.
    e107_pm_blocks NOT found.
    e107_pm_messages NOT found.
    e107_poll NOT found.
    e107_stat_counter NOT found.
    e107_stat_info NOT found.
    e107_stat_last NOT found.
    e107_w1n_lyrics NOT found.
    e107_wmessage NOT found.
    e107_ypslide_cfsaved NOT found.
    002 completes successfully. I did not associate any users as this is a clean install. I processed 25 users p/page (default) and then selected quit

    003 completes successfully. I processed 500 users p/page w/o email matching. All users are imported (3381 users)

    004 hangs. The process starts as expected. Multiple forums are imported however the process has w/ the following displayed on the import screen.

    Import Forum 0 :: 0
    ImpEx build version : 1.87
    Database cleanup & restart ||| Online manual
    Using includes/config.php for target config.

    Importing 10 forums
    From : 0 :: To : 10

    44.44% :: General Discussion
    44.44% :: =(CLANTAG)= Council Discussions
    40.74% :: =(CLANTAG)= Private Discussions
    40.74% :: =(CLANTAG2)= Private Discussions
    44.44% :: Done
    44.44% :: Server Technical Issues
    44.44% :: Joan of Arc's Recruiting Office - Start Here!
    44.44% :: Tech Help
    40.74% :: =(CLANTAG)= Clan Advisors Discussion
    44.44% :: Admin School

    vBulletin® v3.6.8, Copyright ©2000-2008, Jelsoft Enterprises Ltd.
    I have to stop the import at this point or the screen will keep refreshing w/ 44.44%. I let this run for 4 hours overnight w/o success.

    I should mention that I've tried the following settings in php.ini:

    max_execution_time = 30
    max_input_time = 60
    memory_limit = 64M

    max_execution_time = 300
    max_input_time = 600
    memory_limit = 64M

    max_execution_time = 1030
    max_input_time = 1060
    memory_limit = 64M

    max_execution_time = 3600
    max_input_time = 3600
    memory_limit = 64M
    None of the changes made a difference.

    Here are the stats from the e107 board:

    Registered members: 3382
    Unverified members: 189
    Banned users: 83
    Comments: 2546
    Chatbox posts: 14524
    Forum posts: 181088
    Links: 8
    Failed login attempts: 8950
    Here is the server info:

    Server
    Apache/1.3.37 (Unix) mod_ssl/2.8.28 OpenSSL/0.9.7e-p1
    PHP Version
    4.4.4
    MySQL
    5.0.22
    Database: yeahright
    Charset
    utf-8


    In order to test this migration I:
    1. performed clean install of vB
    2. closed source site for posting
    3. performed mysqldump of source site
    4. opened source site for posting
    5. created new database for source test site
    6. imported .sql data into new source test site database
    7. configured impex to point to the new database
    8. copied source site content (files) to new test site location
    9. verified the source test forums work.
    10. closed source test forum
    11. performed import
    12. pulled hair out
    13. searched vB site and google for answers
    14. posted here
    I also restarted (no stop/start, but restart) apache after each php.ini change.

    So, here we are... any thoughts on this. If I can't get input here I'll open a support ticket. Also, I did have a similar problem 2 years ago doing an e107 import into vB 3.4x and 3.5x. This was resolved with a change to the my impex version.

  • #2
    Did the page select categories then go to 10 forums or just keeps reselecting 10 categories ?

    How many did you select for it to do per page ?

    To start again browse directly to : <folder>/impex/help.php and deleting the imported data and session.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      When I click the "start module" button for 004 I get the following:

      Forums to import per cycle (must be greater than 1)

      I have tried the following values: 50 (default), 2, 10, and 20. These all failed. It was looping on categories.

      Here is the odd thing. I did two things different tonight and now it works.

      First, I used the impex direct access method rather than trying to access impex via admincp. Second, I change the import value to 100. Now I show 86 forums imported, 0 errors.

      I'm going to continue w/ the rest of the import and see if anything else fails. Once done, I'll reinstall vBulletin and do a new import:

      Test scenario 1 will be to access impex via admincp and simply change the number from 50 to 100 as the number of imported forums at once.

      Test scenario 2 will be to access impex directly and leave everything default.

      Test scenario 3 will be to access impex directly and change the value from 50 to 100 as the number of forums to import at once.

      I'll post what I find and hopefully that will help others.

      Comment


      • #4
        001 - Check and update database 1 0 1 sec(s)
        002 - Associate Users 0 0 0 sec(s)
        003 - Import User 3381 0 24 sec(s)
        004 - Import Forum 86 0 1 sec(s)
        005 - Import Thread 16095 0 1 min(s)
        006 - Import Post 181087 1 27 min(s)
        007 - Import Poll 0 0 1 sec(s)
        008 - Import Private messages 55303 0 5 min(s)

        So that seemed to work w/ the exception of one failed post and none of the polls imported. I think I had a similar problem w/ e107 polls last time. At that time polls were orphaned. I'm not sure why none imported this time.

        I'll try my test scenarios tonight or tomorrow.

        Comment


        • #5
          I reinstalled vB and ran the import again. This time, I changed the number of forums to import in section 004 from 50 to 100 and everything worked great.

          I'll let you know how the rest of the import goes.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X