Announcement

Collapse
No announcement yet.

impex error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • impex error

    Ok I get this error when trying to import my PHPbb board. Any ideas?








    ltering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
    moderator - importmoderatorid Completed
    usergroup - importusergroupid Completed
    ranks - importrankid Completed
    poll - importpollid Completed
    forum - importforumid Completed
    forum - importcategoryid Completed
    user - importuserid Completed
    style - importstyleid Completed
    thread - importthreadid Completed
    post - importthreadid Completed
    thread - importforumid Completed
    smilie - importsmilieid Completed
    pmtext - importpmid Completed
    avatar - importavatarid Completed
    customavatar - importcustomavatarid Completed
    customprofilepic - importcustomprofilepicid Completed
    post - importpostid Completed
    attachment - importattachmentid Completed
    pm - importpmid Completed
    usernote - importusernoteid Completed
    phrase - importphraseid Completed
    subscription - importsubscriptionid Completed
    subscriptionlog - importsubscriptionlogid Completed

    Valid found tables :


    Possibly custom tables or incorrect prefix :

    attachments NOT found.
    attachments_desc NOT found.
    auth_access NOT found.
    banlist NOT found.
    categories NOT found.
    config NOT found.
    confirm NOT found.
    disallow NOT found.
    forum_prune NOT found.
    forums NOT found.
    groups NOT found.
    posts NOT found.
    posts_text NOT found.
    privmsgs NOT found.
    privmsgs_text NOT found.
    ranks NOT found.
    search_results NOT found.
    search_wordlist NOT found.
    search_wordmatch NOT found.
    sessions NOT found.
    smilies NOT found.
    themes NOT found.
    themes_name NOT found.
    topics NOT found.
    topics_watch NOT found.
    user_group NOT found.
    users NOT found.
    vote_desc NOT found.
    vote_results NOT found.
    vote_voters NOT found.
    words NOT found.

    If you have all red tables, i.e. none correct this could possible be your table prefix :

    phpbb_att_
    Failed Check database permissions and connection, or table prefix to ensure its correct

  • #2
    You have not added the correct source table prefix to your ImpExConfig.php file.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,
      Ok now I added phpbb_att_to the to the impex file but now i get this

      mpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
      moderator - importmoderatorid Completed
      usergroup - importusergroupid Completed
      ranks - importrankid Completed
      poll - importpollid Completed
      forum - importforumid Completed
      forum - importcategoryid Completed
      user - importuserid Completed
      style - importstyleid Completed
      thread - importthreadid Completed
      post - importthreadid Completed
      thread - importforumid Completed
      smilie - importsmilieid Completed
      pmtext - importpmid Completed
      avatar - importavatarid Completed
      customavatar - importcustomavatarid Completed
      customprofilepic - importcustomprofilepicid Completed
      post - importpostid Completed
      attachment - importattachmentid Completed
      pm - importpmid Completed
      usernote - importusernoteid Completed
      phrase - importphraseid Completed
      subscription - importsubscriptionid Completed
      subscriptionlog - importsubscriptionlogid Completed

      Valid found tables :

      phpbb_att_config found.

      Possibly custom tables or incorrect prefix :

      phpbb_att_attachments NOT found.
      phpbb_att_attachments_desc NOT found.
      phpbb_att_auth_access NOT found.
      phpbb_att_banlist NOT found.
      phpbb_att_categories NOT found.
      phpbb_att_confirm NOT found.
      phpbb_att_disallow NOT found.
      phpbb_att_forum_prune NOT found.
      phpbb_att_forums NOT found.
      phpbb_att_groups NOT found.
      phpbb_att_posts NOT found.
      phpbb_att_posts_text NOT found.
      phpbb_att_privmsgs NOT found.
      phpbb_att_privmsgs_text NOT found.
      phpbb_att_ranks NOT found.
      phpbb_att_search_results NOT found.
      phpbb_att_search_wordlist NOT found.
      phpbb_att_search_wordmatch NOT found.
      phpbb_att_sessions NOT found.
      phpbb_att_smilies NOT found.
      phpbb_att_themes NOT found.
      phpbb_att_themes_name NOT found.
      phpbb_att_topics NOT found.
      phpbb_att_topics_watch NOT found.
      phpbb_att_user_group NOT found.
      phpbb_att_users NOT found.
      phpbb_att_vote_desc NOT found.
      phpbb_att_vote_results NOT found.
      phpbb_att_vote_voters NOT found.
      phpbb_att_words NOT found.

      If you have all red tables, i.e. none correct this could possible be your table prefix :

      phpbb_att_ext_


      Then when i change it to phpbb_att_ext_ i get the same error but it says i need to phpbb_att_ .... Not sure what is happening.. maybe you can shed some light on this.. thank you for your help

      Comment


      • #4
        Steve,
        This may help.. my PHbb board has the Categories hierarchy mod on it. I have seen that you have helped others with this mod .. maybe that piece of info will help?

        Comment


        • #5
          That means you are still not using the correct table prefix or db name.

          As for that mod, if it changed the phpBB database then it's possible this would cause Impex not to work. Impex is designed to work with the default phpBB database.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Ok got the import to work on the test data base and got everything worked out. All threds were moved and users. . now how do I move all of that over to the real board. Do i delete the old PHbb board and just copy the VBulletin board over?...

            sorry for the newb questions.. thank you for your help

            Comment


            • #7
              What do you mean by 'real board'?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                ok figured I got the board on the live server and all looks good but the imported members cannot log in only newley created members can. If you go to the members list it shows all of the members but they cant log in. I cant even log in as the admin on the live board.. but If I create a new account everything works great. Any ideas?

                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  What do you mean by 'real board'?
                  The real board I ment the live server the the current PHPBB board is on. . I had the VB on a test server and imported all the info from the PHPBb board to it.. I was just wondering how to get the VB board onto the live server? What I did was just copied the test server files to the live server.. is this ok?

                  Comment


                  • #10
                    Sounds like you haven't updated the usergroups :

                    http://www.vbulletin.com/docs/html/impex_cleanup
                    I wrote ImpEx.

                    Blog | Me

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X