Announcement

Collapse
No announcement yet.

Able to cont Impex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Able to cont Impex

    i have tried various ways of moving my attachments to new board and keep getting errors like this :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 9492225 bytes) in /admincp/impex/ImpExDatabaseCore.php on line 1306

    i doing 10 attachments at a time and taking them from the file system and then putting them into the mysql database.


    Just updating the ImpExDatabaseCore.php from new version of impex

    and still it happens

    Importing 10
    From : 700 :: To : 710


    Failed :: Attachment not imported
    Failed :: Attachment not imported
    Failed :: Attachment not imported
    Failed :: Attachment not imported
    66.67% Attachment -> dead 2.jpg
    66.67% Attachment -> dead meat.rar
    66.67% Attachment -> desp 2.jpg
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 8460365 bytes) in /admincp/impex/ImpExDatabaseCore.php on line 1306

  • #2
    Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' variable in php.ini to at least 32M.

    To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 32 * 1024 * 1024);

    Comment


    • #3
      hi m8 cheers for your help because if cant sort out this attachment problem i have to restart the board again and move attachments for well over 4000 threads.Not a task i look forward to.

      Will send email to host now.

      Comment


      • #4
        i have over 33 gigs of attachments will these store in the sql database as im impexing them there from my old board to new board so i can start afresh.Just dont want to start it and then find out mysql cant handle this amount of imformation.

        Comment


        • #5
          because it crashed out on attachments had to restart it all again - and now when i finally get round to doing the attachments again its just a blank screen - nothing changes at all.(Also ive just grabbed latest impex from here and uploaded that and its still same)

          Comment


          • #6
            3rd try now and this is all that happens when i go to move attachments - correct path as well - its not throwing up no errors its just not doing anything


            Remove ImpEx once import is complete and final
            ImpEx build version : 1.85

            Database cleanup & restart ||| Online manual
            Using ImpExConfig.php for target config.

            Comment


            • #7
              Able to cont Impex

              i have managed to impex everything from my old forum such as threads/posts/polls avatars etc but when i go to attachments the screen goes blank and thats it.
              How do i get it to work without having to import all the information again as selecting clear ids or the sessions removes everything so i have to import all over again just so i can get to the attachments option.

              Comment


              • #8
                Originally posted by StrongMotive View Post
                Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' variable in php.ini to at least 32M.

                To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                ini_set('memory_limit', 32 * 1024 * 1024);

                added the line to config.php and it worked for a while then crashed out again.


                is 32 the max u are allowed to allocate.






                Importing 20
                From : 680 :: To : 700


                66.67% Attachment -> powers series.jpg
                Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2538179 bytes) in /admincp/impex/ImpExFunction.php on line 180




                changed to 128 in config file and still got same error

                Importing 20
                From : 680 :: To : 700


                Failed :: Attachment not imported
                Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2538179 bytes) in /home/custom/public_html/ccnew/admincp/impex/ImpExFunction.php on line 180

                Comment


                • #9
                  32 is not the maximum you can go up to 64, but the server are using may suspend you for overused resource - if you have your own server then its fine to do it while no one else is browsing (as it will be slow for them)

                  Comment


                  • #10
                    im on a dedicated so im fine but i even changed it to 512 and still got same error as listed above.

                    So looks like im out of solutions.

                    as you can see here i have it set to 24

                    PHP 5.2.4 PHP
                    Max Post Size 8.00 MB
                    PHP Maximum Upload Size 2.00 MB
                    PHP Memory Limit 24.00 MB
                    MySQL Version 4.1.22-standard
                    MySQL Packet Size 8.00 MB


                    some of the attachments on my board i know are about 8 meg in size as we set the board up so members can upload upto a size of 8megs.

                    Comment


                    • #11
                      Does impex show if the attachments imported?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        yeah ive had it where its done a few but most of the times it just goes blank.
                        Once it does that the only way is erase the database and impex everything back in again because deleting session ids does not allow you to go straight back and carry on trying to import attachments - you need to start at top with checking databases and work your way back down the list.

                        Very annoying.

                        Comment


                        • #13
                          Can you please post a picture of the completed modules? I still don't understand.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            i cant post a pic as i have to delete all session ids in impex to go back to main screen.
                            Everything is impexed over except the attachments - it starts it and then comes up with an error like this :

                            Importing 20
                            From : 680 :: To : 700


                            Failed :: Attachment not imported
                            Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2538179 bytes) in admincp/impex/ImpExFunction.php on line 180

                            I have increased the phpini memory limit as you can see by the stats below but same error all time.

                            Server Type Linux
                            Web Server Apache v1.3.39
                            PHP 5.2.4
                            PHP Max Post Size 8.00 MB
                            PHP Maximum Upload Size 2.00 MB
                            PHP Memory Limit 32.00 MB
                            MySQL Version 4.1.22-standard
                            MySQL Packet Size 8.00 MB

                            Comment


                            • #15
                              Your PHP does not have enough memory allocated to it to complete this operation. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                              ini_set('memory_limit', 128 * 1024 * 1024);
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X