Announcement

Collapse
No announcement yet.

Troubles with import: generated database errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Troubles with import: generated database errors

    When i try to import the posts and the pms (from a very heavy db) i get, after a long period of import (it don't come soon, but after 20000, 100.000, 200.000... random number of posts/pm) i get an error like that:

    Code:
    Database error
    The SoftAir Mania database has encountered a problem.
    Please try the following:
    
        * Load the page again by clicking the Refresh button in your web browser.
        * Open the www.mydomain.com home page, then try to open another page.
        * Click the Back button to try another link.
    
    The area51.softairmania.it forum technical staff have been notified of the error, though you may contact them if the problem persists.
     
    We apologise for any inconvenience.
    
    Database error in vBulletin 3.6.8:
    
    Invalid SQL:
    
                        UPDATE session
                        SET lastactivity = 1190136205, inforum = 0, inthread = 0, incalendar = 0, badlocation = 0
                        WHERE sessionhash = '789b18a58f8d59ac90b4af921f773467';
    
    MySQL Error  : MySQL server has gone away
    Error Number : 2006
    Date         : Tuesday, September 18th 2007 @ 07:31:51 PM
    Script       : http://www.mydomain.com/forum/impex/index.php
    Referrer     : http://www.mydomain.com/forum/impex/index.php
    IP Address   : xx.xx.xx.xx
    Username     : my_user
    Classname    : vb_database
    
    HTTP/1.1 200 OK Date: Tue, 18 Sep 2007 17:31:53 GMT Server: Apache/2.2.3 (Debian) PHP/4.4.4-8+etch4 X-Powered-By: PHP/4.4.4-8+etch4 Cache-Control: private Pragma: private Keep-Alive: timeout=8, max=67 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html; charset=ISO-8859-1 Content-Language: it 2225
    I tried to give more memory at php session (now it's at 20M for session) and the time out of mysql database (wait_timeout = 360) and connections (max_connections = 1000) but i give that error too...

    I'm using a dedicated HP server with a xeon 2,4ghz with 2gb of ram, i'm not using a virtual server...

    Any ideas?

  • #2
    Run ImpEx standalone, i.e. outside of the admincp and raise the PHP limit to 128M or something like that and time out =0.

    http://www.vbulletin.com/forum/showthread.php?t=161907

    "from a very heavy db" = over 1 million posts ? source system ?
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      mmmm http://www.softairmania.it/forum

      phpbb with ch and stats form db:

      phpbb_users: 4.780
      phpbb_posts: 365.591
      phpbb_topics: 24.747
      phpbb_privmsgs: 55.065

      But when i Import post, pm and topic, the impex counter is more high of the real number of post (about double)

      PHP limit to 128M or something like that and time out =0.
      Can i set that values only at a virtualhost? if i set that for all my virtualhost i'll kill my server, i've a good load of user for day

      Comment


      • #4
        Running ImpEx stand alone will lower the over head and make it slightly faster, it will only import the amount of data in the source database.
        I wrote ImpEx.

        Blog | Me

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X