Announcement

Collapse
No announcement yet.

YaBB 2.0 to VB 3.6.8 so close yet so far

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • YaBB 2.0 to VB 3.6.8 so close yet so far

    I had installed impex into admincp folder and after move up one level, import starts.

    I am at the import Module 001 and I get the following error.

    Failed Check database permissions and connection, or table prefix to ensure its correct

    Help!


  • #2
    This means that you cannot connect to the source database. Make sure that db is on the same server as vB and that you have the correct source db info in ImpExConfig.php.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      This means that you cannot connect to the source database. Make sure that db is on the same server as vB and that you have the correct source db info in ImpExConfig.php.
      This is the part that confuses the daylights out of me- Where is the YaBB DB?

      I can see three db on the server, including the one I created. Maybe trial and error to see if one of the other two is what works?

      Thanks for the quick reply Steve.

      Comment


      • #4
        For YaBB2 as it's a flat file system, you have to enter the correct paths to the forum and uploads folder so ImpEx knows where they are to continue.

        The target database is the vBulletin one.
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Originally posted by Jerry View Post
          For YaBB2 as it's a flat file system, you have to enter the correct paths to the forum and uploads folder so ImpEx knows where they are to continue.

          The target database is the vBulletin one.
          Do you know where I can find the upload folder?

          Comment


          • #6
            Originally posted by BoredOutOfMyMind View Post
            Do you know where I can find the upload folder?
            YaBB installed to the /public_html/cgi-bin/yabb2

            Should be a breeze now.

            Comment


            • #7
              It has installed about 17700 of 60000 threads and some are giving the error that /dir not found meaning the other forums are not coming over. Can I do that step again, or do I need to interupt and start again? It is very slow going.

              Comment


              • #8
                If it's file missing on that module, it's just going to be the threads not the whole forum.

                Raising the PHP memory limit and doing more items per page is the main way of speeding things up.
                I wrote ImpEx.

                Blog | Me

                Comment


                • #9
                  Originally posted by Jerry View Post
                  If it's file missing on that module, it's just going to be the threads not the whole forum.

                  Raising the PHP memory limit and doing more items per page is the main way of speeding things up.

                  I did increase the PHP memory using information from another thread. Will I be able to go in agian and import users/forums? Or do I start over- if so, how do I start over? I have about 2/3 done now of the threads.....

                  Comment


                  • #10
                    Originally posted by BoredOutOfMyMind View Post
                    I did increase the PHP memory using information from another thread. Will I be able to go in agian and import users/forums? Or do I start over- if so, how do I start over? I have about 2/3 done now of the threads.....
                    If you re-run the forum then threads module, it will delete any previously imported data before running that module again.
                    I wrote ImpEx.

                    Blog | Me

                    Comment


                    • #11
                      Originally posted by Jerry View Post
                      If you re-run the forum then threads module, it will delete any previously imported data before running that module again.
                      Sigh,

                      I am in the 4th day of this now . There are 60000 threads and I am at 50,000. If you are saying I have to do it all over again, how do I kill the process and start over? Or do I let it finish it's course and start again.

                      Do I need to fully close the Yabb board to make this happen correctly?

                      Comment


                      • #12
                        Originally posted by BoredOutOfMyMind View Post
                        Sigh,

                        I am in the 4th day of this now . There are 60000 threads and I am at 50,000. If you are saying I have to do it all over again, how do I kill the process and start over? Or do I let it finish it's course and start again.

                        I would be very supprised if it went past 4 hours with that many threads, I would do 5-10,000 per page here with 512M for PHP.

                        Originally posted by BoredOutOfMyMind View Post
                        Do I need to fully close the Yabb board to make this happen correctly?
                        Nope, don't close the source till the tests are good, it might have some incomplete data though you'll see what the process is like.
                        I wrote ImpEx.

                        Blog | Me

                        Comment


                        • #13
                          Ok, I need some serious help on this. The board said there were 61700 posts and now it is processing post 68000.

                          How can I get further help on this import now 3 days longer than I expected?

                          Thanks in advance.

                          Comment


                          • #14
                            What did you expect it to take from testing ?

                            You can contact support and their or I will see what is going on, though if you have a very limited server then there may not be many options.
                            I wrote ImpEx.

                            Blog | Me

                            Comment


                            • #15
                              Originally posted by Jerry View Post
                              What did you expect it to take from testing ?

                              You can contact support and their or I will see what is going on, though if you have a very limited server then there may not be many options.
                              I understood the Impex would inport Yabb into VB.
                              I am guessing I either did something wrong, or the server has limitations.

                              I expected from reading from others to take up to 4-6 hrs to convert this and now after 5 days I am back against the wall unable to figure this out on my own.

                              Do I contact VBSupport with a ticket, or PM you or what means?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X