Announcement

Collapse
No announcement yet.

Import Post not importing posts...?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import Post not importing posts...?

    I'm not sure which step I'm messing up here.

    I'm importing a very small Yahoo Group. Jerry has helped with some earlier steps, I've spent 12 hours of trial and error figuring more out but am stuck on the import step.

    I used phpMyAdmin to import the database, it claims to have all 633 posts ("records") in the db table.

    In ImpEx (1.83), under "Altering Tables," everything is "OK."

    On the screen with the "Start Module" (or "Redo Module") buttons, here's what happens:

    Check and update database: Successful: 1, Failed: 0
    Import User: Successful: 53, Failed: 0
    Import Forum: Successful: 3, Failed: 0
    Import Thread: Successful: 0, Failed: 0
    Import Post: Successful: 0, Failed: 0


    Just in case, I went ahead and ran the "Update Counters," etc. in AdminCP. The new forum shows up in vBulletin, but no threads or posts are inside.

    In Forum Manager, there was a strange URL (not in URL format) listed under "Forum Link," that lead to a nonexistent page, so I deleted it. Still no luck.

    Any tips on how to troubleshoot this?

    Thanks!

    ETA: I don't know why it would list 3 forums imported, as there was only 1.
    Last edited by glennno; Sun 5 Aug '07, 1:19am. Reason: Added "Start Module" correction

  • #2
    check this out:
    http://www.vbulletin.com/docs/html/main/impex_cleanup

    did you do:

    Forum cache

    To rebuild the forum cache so your imported forums appear, go to your forum manager and save the display.

    Comment


    • #3
      Thanks, Dagoor. Good news/bad news. Good: You pegged the step I missed! Doh! Bad: Unfortunately, it didn't change anything.

      Of course I know nothing, but it seems to me the problem happened before that, no? Since no threads or posts got imported with the "Start Module" buttons? Unless they all come over in a single bunch in the database?

      Should I start the whole process over but do the Forum Manager/Save the Display step before updating counters? Or does that order not have much effect?

      Thanks.

      Comment


      • #4
        I removed and then redid everything, getting that step right.

        Still no luck, but now there's a mysterious thread called "Yahoo catchments thread" in the forum. It is empty, with the description "!##NULL##!"

        ???

        Comment


        • #5
          Never mind, I got someone to come help. If the problems were unique, I'll post them for helping others.

          One thing I noticed: Any apostrophes in Yahoo Group post subjects prevent those posts from importing with ImpEx.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X