Announcement

Collapse
No announcement yet.

Please HELP URGENTT... Database problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please HELP URGENTT... Database problem.

    Hey there

    I ran the impex script perfectly until i got to attachments.
    When I clicked on 'run attachment module'
    this is what i got:

    ImpEx Database errormysql error: Invalid SQL:
    SELECT * FROM xmb_attachments
    ORDER BY aid
    LIMIT 0,

    mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

    mysql error number: 1064

    Date: Tuesday 31st of July 2007 04:39:49 PM
    Database: mario_ohfor
    MySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3





    please help, what should i do?

  • #2
    SQL Syntax errors are almost always related to modified code. To troubleshoot this, the first thing you need to do is remove any hacks or plugins, then see if you still have this problem.

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hey,

      It is a new vBulletin installation.
      I don't have any hacks nor plugins.

      Secondly... in my xmb forum i dont have any plugins nor hacks installed at all.

      I haven't modified anything related to attachments.
      I've submitted a ticket and i havent got anything back.

      Can you please give me support this way?

      I'm importing from XMB

      Comment


      • #4
        There are no unansweered tickets, and no I would not be able to support you on the forums because we will need access to your server and databaase to see what the problem is.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          It is unanswered. I've already posted 2 times.

          [SID-680866-removed] ----- this is the ID

          Comment


          • #6
            Colin has reponded to that ticket 5 times already, as you well know.

            However he does not work 24 hours a day and is not immediately available to instantly respond to every reply. You will need to wait until he is available again.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Is there anyone else that can help me go through this? It's very important i get this done as soon as possible?

              Help is appreciated

              Comment


              • #8
                I'll look at it but in general it is better to have one ticket handled by the same person for continuity, otherwise we don't know what was done and things could get messy.

                However if I don't see anything obvious I will leave it for him.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  You are running Impex 1.82. You need to clear out the imported data and session then download and install Impex 1.83 and try again.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Hey,
                    I downloaded 1.83 and installed, and re-ran all the modules again and I'm still getting the same error.

                    what else can I do?

                    Comment


                    • #11
                      Originally posted by mariolop View Post
                      Hey,
                      I downloaded 1.83 and installed, and re-ran all the modules again and I'm still getting the same error.

                      what else can I do?
                      I've just double checked it here and that's a valid session variable that's being dropped and not passed, though its in ImpEx. I can usually only re-create this error by pressing refresh during the page load.

                      I've updated the files :

                      impex/systems/xmb/000.php
                      impex/systems/xmb/010.php

                      in the 1.83 ImpEx download to trap that if it's not being passed.

                      Though as to why yours isn't you'll have to open a support ticket so we can have a look at it in action.
                      I wrote ImpEx.

                      Blog | Me

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X