Announcement

Collapse
No announcement yet.

1.82 Issue: Forum Module->missing showprivate column

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.82 Issue: Forum Module->missing showprivate column

    When upgrading from 3.5.4 into 3.5.8 I'm getting:

    mysql error: Unknown column 'showprivate' in 'field list'

    Neither version have that column, so I assume it's a bug ... ?
    ::Typhon::
    www.realmworx.com

  • #2
    Please redownload impex and reinstall it then try again.
    Kerry-Anne :)

    Twitter Blog

    www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

    Comment


    • #3
      Still an issue .. I have 1.83 installed and when I go to the forum module it's trying to select a column called forum.showprivate ... which doesn't exist in 3.5.* .
      ::Typhon::
      www.realmworx.com

      Comment


      • #4
        Originally posted by Typhon View Post
        When upgrading from 3.5.4 into 3.5.8 I'm getting:

        mysql error: Unknown column 'showprivate' in 'field list'

        Neither version have that column, so I assume it's a bug ... ?
        Are you upgrading or importing ?

        From vBulletin to vBulletin you should be upgrading and not importing.

        There is no SQL in impex that specifically selects showprivate in any system or import function.
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Originally posted by Jerry View Post
          Are you upgrading or importing ?

          From vBulletin to vBulletin you should be upgrading and not importing.

          There is no SQL in impex that specifically selects showprivate in any system or import function.
          I'm importing ... and the error is:

          Code:
          ImpEx Database errormysql error: Invalid SQL: 
                              INSERT INTO forum
                              (
                                  styleid, title, options,
                                  displayorder, parentid, importforumid,
                                  importcategoryid, description, replycount,
                                  lastpost, lastposter, lastthread,
                                  lastthreadid, lasticonid, threadcount,
                                  daysprune, newpostemail, newthreademail,
                                  parentlist, password, link, childlist,
                                  title_clean, description_clean,
                                  showprivate, lastpostid, defaultsortfield,
                                  defaultsortorder
                              )
                              VALUES
                              (
                                  [values hidden by me]
                              )
                          
          
          mysql error: Unknown column 'showprivate' in 'field list'
          
          mysql error number: 1054
          
          Date: Monday 30th of July 2007 05:43:00 PM
          Database: ImpEx
          MySQL error:
          ::Typhon::
          www.realmworx.com

          Comment


          • #6
            Ahhhh 3.5.8.

            Download ImpEx again and upload and overwrite :

            impex/ImpExDatabase_350.php

            I've updated the file in the 1.83 download.

            Also, what's the reason you are importing opposed to upgrading ?
            I wrote ImpEx.

            Blog | Me

            Comment


            • #7
              I've got to consolidate my sites first ... and let things settle a bit while I make the needed style and forum modifications on my 3.6.8 board, at which point I will be upgrading. Baby steps so to say. I have too much custom stuff that i'm trying to unravel .
              ::Typhon::
              www.realmworx.com

              Comment


              • #8
                FYI:

                now it says:

                Code:
                mysql error: Unknown column 'lastpostid' in 'field list'
                I ended up having to remove a ton of fields from the forum module import... and it's looking it's it's going to be the same for threads as well. Can I get an official impex from 3.5.* to 3.5.*?
                Last edited by Typhon; Mon 30 Jul '07, 7:34pm.
                ::Typhon::
                www.realmworx.com

                Comment


                • #9
                  Originally posted by Typhon View Post
                  FYI:

                  now it says:

                  Code:
                  mysql error: Unknown column 'lastpostid' in 'field list'
                  Giving a small sliver of the error dosn't really help, I'd need to see it in context of the SQL.

                  Originally posted by Typhon View Post
                  I ended up having to remove a ton of fields from the forum module import... and it's looking it's it's going to be the same for threads as well. Can I get an official impex from 3.5.* to 3.5.*?
                  Hacking out code from the modules wont do anything for the SQL, the system is more complex than that.

                  3.5 -> 3.5 is support at the moment, though I would need access to the site via a support ticket I can't check the errors for something like that from here and seeing what condition the sites are in, by the looks of it you have a hacked 3.5 as a target.

                  I'd advise just import into vBulletin 3.6.
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    I actually chose the option to export to 3.5.8 .. from the drop down. Is that option no longer valid? I'll see about exporting straight into 3.6.8.
                    ::Typhon::
                    www.realmworx.com

                    Comment


                    • #11
                      Originally posted by Typhon View Post
                      I actually chose the option to export to 3.5.8 .. from the drop down. Is that option no longer valid? I'll see about exporting straight into 3.6.8.
                      Yes, though I've updated the ImpEx download for 3.5 as I changed it around for the 1.83 release that could affected this, download again and have another go and if it happens again then start a support ticket and ask for me.
                      I wrote ImpEx.

                      Blog | Me

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X