Announcement

Collapse
No announcement yet.

Failure on 1st step - edithistorypermissions doesn't have a default value

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failure on 1st step - edithistorypermissions doesn't have a default value

    Trying to import into VB from Snitz. The VB install only has a little test data that was created when I was testing the install. NO merge necessary.

    Source: Snitz 3.4.04
    Target: VB 3.6.7 PL1
    Module: 001
    Error: mysql error: Field 'edithistorypermissions' doesn't have a default value
    Impex Build: 1.81
    Any idean what I should do with this? Also, how do I go about purging all the test data in the new VB database that was created when I was testing prior to importing?


    ------------------------------------------------
    Altering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
    moderator - importmoderatorid Completed
    usergroup - importusergroupid Completed
    ranks - importrankid Completed
    poll - importpollid Completed
    forum - importforumid Completed
    forum - importcategoryid Completed
    user - importuserid Completed
    style - importstyleid Completed
    thread - importthreadid Completed
    post - importthreadid Completed
    thread - importforumid Completed
    smilie - importsmilieid Completed
    pmtext - importpmid Completed
    avatar - importavatarid Completed
    customavatar - importcustomavatarid Completed
    customprofilepic - importcustomprofilepicid Completed
    post - importpostid Completed
    attachment - importattachmentid Completed
    pm - importpmid Completed
    usernote - importusernoteid Completed
    phrase - importphraseid Completed
    subscription - importsubscriptionid Completed
    subscriptionlog - importsubscriptionlogid Completed

    There seems to have been a problem with the database.
    ImpEx Database errormysql error: Invalid SQL:

    INSERT INTO TGusergroup
    (
    importusergroupid, title, description,
    usertitle, passwordexpires, passwordhistory,
    pmquota, pmsendmax,
    opentag, closetag, canoverride,
    ispublicgroup, forumpermissions, pmpermissions,
    calendarpermissions, wolpermissions, adminpermissions,
    genericpermissions, genericoptions, attachlimit,
    avatarmaxwidth, avatarmaxheight, avatarmaxsize,
    profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize,
    signaturepermissions, sigpicmaxwidth, sigpicmaxheight,
    sigpicmaxsize, sigmaximages, sigmaxsizebbcode, sigmaxchars,
    sigmaxrawchars, sigmaxlines
    )
    VALUES
    (
    '69',
    'Imported Users',
    '',
    '',
    0,
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    '',
    ''
    )

    mysql error: Field 'edithistorypermissions' doesn't have a default value
    mysql error number: 1364
    Date: Saturday 26th 2007f May 2007 09:58:58 AM
    Database: ridingaz
    MySQL error: Field 'edithistorypermissions' doesn't have a default value
    ------------------------------------------------
    stwilson

  • #2
    Check the Password History setting for each Usergroup. What are they set to?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      They were all set to zero, except for the Administrator group. I am assuming I should change that one to zero too? Thanks for your reply.
      stwilson

      Comment


      • #4
        Try it and see if that fixes the problem.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I tried that and still the same error.
          stwilson

          Comment


          • #6
            Actually, upon a closer inspection it did change. See the red text below that has changed.

            Altering tables

            ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
            moderator - importmoderatorid Completed
            usergroup - importusergroupid Completed
            ranks - importrankid Completed
            poll - importpollid Completed
            forum - importforumid Completed
            forum - importcategoryid Completed
            user - importuserid Completed
            style - importstyleid Completed
            thread - importthreadid Completed
            post - importthreadid Completed
            thread - importforumid Completed
            smilie - importsmilieid Completed
            pmtext - importpmid Completed
            avatar - importavatarid Completed
            customavatar - importcustomavatarid Completed
            customprofilepic - importcustomprofilepicid Completed
            post - importpostid Completed
            attachment - importattachmentid Completed
            pm - importpmid Completed
            usernote - importusernoteid Completed
            phrase - importphraseid Completed
            subscription - importsubscriptionid Completed
            subscriptionlog - importsubscriptionlogid Completed

            There seems to have been a problem with the database.
            ImpEx Database errormysql error: Invalid SQL:
            INSERT INTO RAusergroup
            (
            importusergroupid, title, description,
            usertitle, passwordexpires, passwordhistory,
            pmquota, pmsendmax,
            opentag, closetag, canoverride,
            ispublicgroup, forumpermissions, pmpermissions,
            calendarpermissions, wolpermissions, adminpermissions,
            genericpermissions, genericoptions, attachlimit,
            avatarmaxwidth, avatarmaxheight, avatarmaxsize,
            profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize,
            signaturepermissions, sigpicmaxwidth, sigpicmaxheight,
            sigpicmaxsize, sigmaximages, sigmaxsizebbcode, sigmaxchars,
            sigmaxrawchars, sigmaxlines
            )
            VALUES
            (
            '69',
            'Imported Users',
            'Usergroup description',
            '',
            0,
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            '',
            ''
            )

            mysql error: Field 'edithistorypermissions' doesn't have a default value
            mysql error number: 1364
            Date: Sunday 27th 2007f May 2007 06:45:08 PM
            Database: ridingaz
            MySQL error: Field 'edithistorypermissions' doesn't have a default value

            stwilson

            Comment


            • #7
              Strange one. Fill out a support ticket at:

              http://members.vbulletin.com/members...ontactform.php

              Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Set :

                PHP Code:
                define('forcesqlmode'true); 
                In ImpExConfig.php
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X