Announcement

Collapse
No announcement yet.

Snitz import for dummies (MS-SQL or MS-Access)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    try the following (assuming your database is in standard latin1 encoding):
    mysqlimport -h host -u username -p --character-sets-dir=latin1 dbname c:\dbdump.sql

    But there could be some problems with delimiters, fields enclosing caracters etc...

    If this is not working as is, then try to include the following parameters in my.ini file and restart Mysql then:
    Code:
    [mysqlimport]
    fields-terminated-by=;
    default-character-set=latin1
    fields-enclosed-by="
    lines-terminated-by=\r\n
    Last edited by ALcorn; Thu 7 Feb '08, 4:10am.

    Comment


    • #17
      help with Snitz import please

      I am trying to convert a very small Snitz forum over to the latest version of vB.

      I downloaded the trial version of Intelligent Converters, and did a direct import into MySQL database.

      I had set up the MySQL database thru phpMYadmin and left it empty, leaving the converter to populate the fields.

      Two issues.
      1) Many table names are failing. ie. FORUMS_CATEGORY winds up as forums_cat_gory

      2) The target database tabe names are in lowercase. It seems like IMPEX is seeking uppercase tabel names as IMPEX is not finding the table names that do come over correctly.

      Any help appreciated.

      Thanks
      Kerry

      Comment


      • #18
        Not sure what's going on with the table name though you can re-name it, unless it's a newer version I haven't seen.

        In ImpExConfig you have this directive you can set at the bottom :

        PHP Code:
        define('lowercase_table_names'true); 
        I wrote ImpEx.

        Blog | Me

        Comment


        • #19
          very close now

          Thanks Jerry, with that last message I think I am almost home.

          The problem with the table names seems to be restricted to the trial version of the Intellegent Converters software. When I purchased the full version the problem went away.

          I have done the import, and I went into maintenence and ran all of the index updates, and all is looking good except for one thing.

          When I click on memberlist i see only the admin. When I go into the CP, I see them all and they are all editable.

          The forums and posts came in fine, and the posts all have the right username attached.

          Any idea why members dont show?

          Thanks for your help
          Kerry

          Comment


          • #20
            users are banned after import

            Users are resetting their passwords, but getting a message saying:

            You have been banned for the following reason:
            No reason was specified.
            Date the ban will be lifted: Never

            In the CP, if I click on banned users I get nothing. Nobody is banned.

            Any ideas?
            Thanks
            Kerry

            Comment


            • #21
              OK. Figured out banned users. I'm just now noticeing not all posts and threads came in.

              Oh well. retry
              Kerry

              Comment


              • #22
                Are you sure it's not this:

                How Do I Set Forums to Display All Posts
                http://www.vbulletin.com/forum/showthread.php?t=191791
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #23
                  Steve! You did it. That was it exactly.
                  Thank you so much.
                  Kerry

                  Comment


                  • #24
                    You're welcome.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X