Announcement

Collapse
No announcement yet.

yabb 2 - Forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • yabb 2 - Forums

    I'm trying to import from Yabb 2.1 and only 1 of 20 boards/forums came across and only 1 of 3 categories.

    Before that 1884 of 1887 users imported - while that's completely acceptable for my purposes, I thought I'd mention it in case the forum/category import depends a flawless user import.

    It looks like the first category makes it, then the other two fail ("Failed :: Forum not imported"). That is followed by a series of "Invalid ImpExData object, skipping. Failed on : parentid" messages.

    Unfortunately, I know nothing about PHP so looking at 000.php and 003.php didn't give me any clues other than that I guess impex is looking at a yabb file called forum.control to get forum information. The categories that didn't have an underscore in their ID imported, the ones that did, not so much.

    Here's what a typical line looks like:

    general_cat|GC||a description|comma,delimited,listof,admins|||||0|||||||

    From that point on pretty much everything fails (duh).

    This is probably not related, but only the first post came across for those few threads that did make it into the system. I found the execute SQL and ran "select * from post" (after verifying the table was very small) and, sure enough, only the first posts are there. However, I like to tackle problems one at a time so if you don't have an immediate answer for that, I'd be glad to stick to the problem at hand.

    Edit: Good grief, I just saw another post that looks to be reporting the same thing. Sorry.
    Last edited by flatlander; Wed 18th Apr '07, 2:07am. Reason: just saw another post on the same thing

  • #2
    I was working with a YaBB 2.1 import yesterday, the main issue I'm having is recreating the errors here, I can see the forums failing on their server though can't do it here.

    btw : the forums aren't dependant on the users to import, just the order of the modules. It's the cats failing, then the forums failing as they don't have the cats for a parentid.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      Yeah, I figured I wasn't going to give you the right information. I've got a support ticket started and am sending some information that should allow the vBulletin folks to recreate it.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X