Announcement

Collapse
No announcement yet.

Problem of memory importing forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem of memory importing forum

    I have just bought vbulletin and I am having a problem importing muy old phpbb forum through Impex. This is the message error when importing users table:

    Fatal error: Allowed memory size of 12582912 bytes exhausted (tried to allocate 217 bytes) in /var/www/html/foros/impex/ImpExFunction.php on line 299
    My old forum has 3,566 users, 640,000 messages and 800 MB database.

    Please ask me if you need more information.

    Thank you for your help.

  • #2
    Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' varible in php.ini to at least 32M.

    To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 32 * 1024 * 1024);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      My host has increased the memory to 64 MB.

      It seems that users are importing well, but some names have changed. For example: coupé appears now as coupé

      Is there a way to solve this?

      Thank you.
      Last edited by ismapolo; Sat 31st Mar '07, 11:28am.

      Comment


      • #4
        I don't know. I'll ask the other staff if they know.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          One of the Devs said to change your HTML Character code in the language settings to: UTF-8
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol View Post
            One of the Devs said to change your HTML Character code in the language settings to: UTF-8
            OK How do I do that?

            This problem is causing that registered users with an accent in its name can't get into the forum.

            Thank you.
            Last edited by ismapolo; Sun 1st Apr '07, 4:23am.

            Comment


            • #7
              I have found a solution for small tables:

              PHP Code:
              UPDATE  `tablethread`  SET  `title`  = replace(  `title` ,  "íº ",  "ú"  ) ; 
              But it seems it does not work for big tables.
              Last edited by ismapolo; Sun 1st Apr '07, 8:39am.

              Comment


              • #8
                Admin CP -> Languages & Phrases -> Language Manager -> Edit Settings -> HTML Character Set
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X