Announcement

Collapse
No announcement yet.

Errors on importing users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors on importing users

    Hello.

    I'm in my second attempt to do a phpbb-Nuke -> phpbb -> vBulletin import, using the method posted here:

    http://www.vbulletin.com/forum/showp...58&postcount=4

    I installed a fresh phpbb board and copied and renamed the relevant phpnuke tables to it, as the post describes. (exporting the tables timed-out, but copying them from one db to the other seems to work fine.)

    All forums and posts appeared in the new phpbb board and I was able to log in after editing a couple entries out of the login.php script. I assume they and my lack of admin privileges were due to the following mysql error I am getting again today, when I try again to copy the phpbb_users table over.

    =======================
    INSERT INTO `dbase1-nuke2pbb`.`phpbb_groups`
    SELECT *
    FROM `dbase1`.`nuke_bbgroups`

    MySQL said: Documentation
    #1062 - Duplicate entry '1' for key 1

    =======================
    Error

    SQL-query: Documentation

    SELECT *
    FROM nuke_bbgroups
    WHERE LIKE '1'

    LIMIT 0 , 30

    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIKE '1' LIMIT 0, 30' at line 1
    =======================

    Ideas?

    Thanks.
    Last edited by monet_06; Sun 25 Mar '07, 5:31pm. Reason: Title: groups - not users

  • #2
    I decided to try the impex import of users anyway, just to see if it would work in spite of that error, and it did fine. The only odd thing left is that none of their birthdays imported, and 217 of them show their last activity dates as 12-31-1969.


    I was unable to import posts, for the reason explained below, so I didn't even try, this time.

    Questions: When I make my next attempt to import the forums, threads, and posts, do I need to empty the database and start over with the users modules, again?

    Should I re-run the first module?

    Does it matter that I already did the counter resets, etc after importing users?


    My problem with importing posts remains: There are about 100,000 left after pruning, and it appears to be timing out after about 10,000 of them. I set it to cycle only 1000 at a time. (it runs 1550, anyway, btw)

    We have 32 mb ram for php, so I doubt it is a memory issue, but it might be our server's Spider Rate Control, which stopped the import of posts, yesterday. It blocks ips after they make too many connections in a row. So, I edited the .php config to have it ask me before each page refresh, and I waited 30 seconds to a minute between each, but it still timed-out after about 11,000 posts.

    Should I just keep trying? Wait and then refresh the pages and then use the help.php to remove duplicate forums/threads/posts?

    Thanks

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X