Announcement

Collapse
No announcement yet.

Connection to source server failed - PunBB - Please help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connection to source server failed - PunBB - Please help

    Connection to source server failed. Check username and password.

    I see that there are already lots of posts about this error and I've read most of them, but I just can't find a solution. I'm trying to import posts from Punbb which is installed on the same server.
    My Vbulletin is empty - I just bought the license today - Do I need to configure anything first?


    Here are my settings in ImpexConfig.php:

    Code:
    # If impex is installed in vBulletin you can ignore the target details
    # as includes/config.php
    
    if (!defined('IDIR')) { die; }
    
    # For mysqli enter mysql
    $impexconfig['target']['databasetype']    = 'mysql';
    $impexconfig['target']['server']        = 'localhost';
    $impexconfig['target']['user']            = 'username';
    $impexconfig['target']['password']        = 'password';
    $impexconfig['target']['database']        = 'vbulletin_forum';
    $impexconfig['target']['tableprefix']    = '';
    $impexconfig['target']['charset']        = '';
    
    
    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to true.
    # If the source data is NOT stored in a database, set 'sourceexists' to false
    
    $impexconfig['sourceexists']            = true;
    
    # mysql / mssql
    $impexconfig['source']['databasetype']    = 'mysql';
    $impexconfig['source']['server']        = 'localhost';
    $impexconfig['source']['user']            = 'soulreac_punuser';
    $impexconfig['source']['password']        = 'password';
    $impexconfig['source']['database']        = 'soulreac_punbb';
    $impexconfig['source']['tableprefix']   = '';
    $impexconfig['source']['charset']        = '';
    
    
    # Error logging will log import errors to a database table impexerror
    # for use with support.
    # Language file is the file of phrases to be used, default is english.
    # pagespeed is the second(s) wait before the page refreshes.
    
    $impexconfig['system']['errorlogging']    = true;
    $impexconfig['system']['language']        = '/impex_language.php';
    $impexconfig['system']['pagespeed']        = 1;
    
    define('impexdebug', false);
    define('emailcasesensitive', false);
    define('forcesqlmode', false);
    define('skipparentids', false);
    define('shortoutput', false);
    define('do_mysql_fetch_assoc', false);
    define('step_through', false);
    define('lowercase_table_names', false);
    define('use_utf8_encode', true);
    define('dupe_checking', true);
    Help would be greatly appreciated as I have been trying this for a few hours.

  • #2
    In my experience this is always due to either the wrong source db info or a problem with that database itself.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thank you for the reply Steve. I got it working!

      In case anyone else is pulling their hair out trying to import, here is where I went wrong .

      I started off using the wrong database password. After trying for an hour, I went into my Cpanel and changed the database user's password to make sure that I had the correct password. That still didnt work. When I finally remembered my password, it didnt work because I did not change the password in my old script's (PunBB) config file.

      To avoid this problem, simply check your old database info by looking in your old forums config.php file. Whatever is there, always needs to match what is in your ImpexConfig.php file.

      For Punbb it was simply config.php

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X