Announcement

Collapse
No announcement yet.

Problem with Cyrillic symbols after DB import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Cyrillic symbols after DB import

    After importing DB from source to target i have problem that all cyrillic symbols looks like question symbols ("??????????????????").
    All bases are cp1251_general_ci.

  • #2
    Which BB system did you import from?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I'm importing from vB 3.6.2 to vB 3.6.4.
      Also I tried to import SMF database to vB 3.6.4, but I have the same problem. I think ImpEx causes the problem because all symbols look correct in the tables of database and during the import all cyrillic symbols are shown right, but after finishing of all modules in ImpEx all symbols look like "?????????". Also after I update counters, all cyrillic symbols in the forum are converted to question symbols (latin symbols are ok). If somebody posts new thread or writes something in Russian after importing it's also ok. The problem just in imported data.
      Last edited by avatar80; Mon 5 Mar '07, 8:34pm.

      Comment


      • #4
        Try this. Edit impex/db_mysql.php and change this line:

        $query_id = $query_type(utf8_encode($query_string), $this->link_id);

        To this:

        $query_id = $query_type($query_string, $this->link_id);

        Then redo the import. Let me know if that works.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          No. (
          I have made the import of the users and looked to User Managment in the admincp - "ImpEx - ?????????????????" again.

          Comment


          • #6
            Did you redo the entire import as I suggested?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Yes. I have solved the problem. Your suggestion helped me partially. Thanks a lot.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X