Announcement

Collapse
No announcement yet.

Import interrupted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import interrupted

    Hi,

    Clean import, no previous import just 1 day of usage now having a phpBB board imported

    Source - phpBB2 - 2.0.20
    Target - vBulletin 3.6.4
    Module - 002 - associate users
    Using includes/config.php for target config.


    Despite reading the warning not to move away from the import page, well I did. I clicked on start module for module 2 by mistake and could not get out of it, so I clicked back. Now I cannot return to the import module screen, all I get is

    'Using includes/config.php for target config.'

    Kicking myself for making a silly move like that. How do I dig myself out of this hole? What do I need to do to get back to the module page and import the rest?

    Thanks in advance.
    V

  • #2
    Try going to help.php and restarting the import there. If that doesn't work, run this query and then restart:

    DELETE FROM datastore WHERE title='ImpExSession';
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      Hi Colin F,

      I ran help.php and got this

      'ImpEx can not read the target database details from impex/ImpExConfig.php OR ../includes/config.php.
      Please enter the target database details in ImpExConfig, or run ImpEx installed opposed to standalone.'

      I am a newbie and I have no idea how to run the query
      DELETE FROM datastore WHERE title='ImpExSession';

      Help, I am still stuck.

      Cheers
      V

      Comment


      • #4
        You can run that query in phpMyAdmin or in the 'Execute SQL Query' page of the Maintenance section in your AdminCP.
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Originally posted by Colin F View Post
          You can run that query in phpMyAdmin or in the 'Execute SQL Query' page of the Maintenance section in your AdminCP.

          When I try to execute SQL query, it gives me this message

          'You are not authorized to execute SQL queries'

          I am missing something obviously.

          Cheers
          V

          Comment


          • #6
            To run queries you first need to give yourself permission to run queries in the Admin CP. To do this, edit this section of config.php:
            // ****** USERS WITH QUERY RUNNING PERMISSIONS ******
            // The users specified here will be allowed to run queries from the control panel.
            // See the above entries for more information on the format.
            // Please note that the ability to run queries is quite powerful. You may wish
            // to remove all user IDs from this list for security reasons.
            $canrunqueries = 'x';
            ...with x being your userid number.
            Best Regards
            Colin Frei

            Please don't contact me per PM.

            Comment


            • #7
              Hi Colin,

              Thanks, that worked. I am back to square one (woohoo !)

              Then the bad news. I could not get (PHPBB2) usergroups and users (possibly more modules) to import. Gives me the messages below.

              Module 001
              Altering tables

              ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
              moderator - importmoderatorid Completed
              usergroup - importusergroupid Completed
              ranks - importrankid Completed
              poll - importpollid Completed
              forum - importforumid Completed
              forum - importcategoryid Completed
              user - importuserid Completed
              style - importstyleid Completed
              thread - importthreadid Completed
              post - importthreadid Completed
              thread - importforumid Completed
              smilie - importsmilieid Completed
              pmtext - importpmid Completed
              avatar - importavatarid Completed
              customavatar - importcustomavatarid Completed
              customprofilepic - importcustomprofilepicid Completed
              post - importpostid Completed
              attachment - importattachmentid Completed
              pm - importpmid Completed
              usernote - importusernoteid Completed
              phrase - importphraseid Completed
              subscription - importsubscriptionid Completed
              subscriptionlog - importsubscriptionlogid Completed

              Valid found tables :

              ranks found.

              Possiablly custom tables or incorrect prefix :

              attachments NOT found.
              attachments_desc NOT found.
              auth_access NOT found.
              banlist NOT found.
              categories NOT found.
              config NOT found.
              confirm NOT found.
              disallow NOT found.
              forum_prune NOT found.
              forums NOT found.
              groups NOT found.
              posts NOT found.
              posts_text NOT found.
              privmsgs NOT found.
              privmsgs_text NOT found.
              search_results NOT found.
              search_wordlist NOT found.
              search_wordmatch NOT found.
              sessions NOT found.
              smilies NOT found.
              themes NOT found.
              themes_name NOT found.
              topics NOT found.
              topics_watch NOT found.
              user_group NOT found.
              users NOT found.
              vote_desc NOT found.
              vote_results NOT found.
              vote_voters NOT found.
              words NOT found.

              If you have all red tables, i.e. none correct this could possible be your table prefix :

              phpbb_

              Module 002
              Skipped

              Module 003
              ImpEx Database errormysql error: Invalid SQL:
              SELECT * FROM groups
              WHERE group_single_user=0
              ORDER BY group_id
              LIMIT 0,50
              mysql error: Table 'siliconforum.groups' doesn't exist
              mysql error number: 1146
              Date: Wednesday 21st of February 2007 10:28:12 AM
              Database: siliconforum
              MySQL error: Table 'siliconforum.groups' doesn't exist


              Module 004
              ImpEx Database errormysql error: Invalid SQL:
              SELECT * FROM users
              ORDER BY user_id
              LIMIT 0,2000
              mysql error: Table 'siliconforum.users' doesn't exist
              mysql error number: 1146
              Date: Wednesday 21st of February 2007 09:45:49 AM
              Database: siliconforum
              MySQL error: Table 'siliconforum.users' doesn't exist

              There could be more modules that have the same problem. Please point me in the right direction. Thanks again.

              Regards
              V

              Comment


              • #8
                oh and I tried the prefix phpbb_ as well and that cause module 001 to fail the check.

                V

                Comment


                • #9
                  What's the new results with that prefix?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    The result was module 001 failed the check and the import cannot continue.

                    Cheers
                    V

                    Comment


                    • #11
                      That's all it said?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Hi Steve,

                        When I use phpbb_ as a table prefix, I get this error when I start module 001.

                        'phpbb_ Failed Check database permissions and connection, or table prefix to ensure its correct'

                        I do not get this error when I do not use a prefix. When I try and run module 003 and higher I get this error.

                        'This module is dependent on Check and update database cannot run until that is complete .'

                        I want to add the following observations

                        1. The source board drop down menu only offers one choice, phpbb2 (2.0.21), but I am running phpbb2 (2.0.20).
                        2. I have to Execute SQL Query DELETE FROM datastore WHERE title='ImpExSession'; everytime I get an error message like the ones described above. Will this affect the database ID?

                        Hoping to hear from you.
                        V

                        Comment


                        • #13
                          'Check database permissions and connection, or table prefix to ensure its correct'

                          That means what it says. There is something wrong with one of those items.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Hi Steve,

                            Thanks for your help so far. I have isolated my error to a typo in the table prefix. Thanks for pointing me in that direction.

                            My next problem is importing.

                            I have successfully imported the tables in module 001, skipped 002. In module 004 - the banlists I encountered the following error.

                            'Failed User id ban list

                            Failed IP ban list

                            Failed Email ban list'

                            I do not have any banlists in my forum but that should not produce this error. I have also tried using the 'no' option but it still produces the same error.

                            All other modules had no errors. Should there be a continue button? There is no way to exit the import page and I do not see the categories, members and other related imports in my Vbulletin forum that were imported successfully in module 006. Any help would be greatly appreciated.

                            Cheers
                            V
                            Last edited by Volvoholic; Sun 25 Feb '07, 7:13am.

                            Comment


                            • #15
                              If you had no banlist then it would appear to be normal that importing it would fail. If everything else is correct, then please follow the 'After the Import' instructions here:

                              http://www.vbulletin.com/docs/html/impex_cleanup
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X