Announcement

Collapse
No announcement yet.

Importing Issues from MSSQL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Steve-

    Sorry for my ignorance. But on the same server meaning...if my site is http://www.mysite.com I have my vB forum installed in http://www.mysite.com/forum and have my YAF installed on say http://www.mysite.com/Yaf, then run the import and it should work? Am I correct in thinking this?

    Again thanks for understanding my ignorance, I'm still learning...

    Comment


    • #17
      Yes, I assume that means the databases are on the same server. Have you verified this?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        One database is on an MSSQL server (mssql08.myhost.com) and one is on a MySQL server (mysql22.myhost.com). I can remote connect to both through the php script. They are on the same service under my domain...

        Comment


        • #19
          Actually that looks like two different servers to me. If you are getting the same error as in post #13, then it appears that you are not able to connect to the source server from your vB server.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            The last time I wasn't able to connect to the MSSQL server it came up and stated what was in post #1. Now I get whats in post #13. But I do not have the source code for Yaf installed in my server directory yet...an example of the way I am thinking would be if I was transferring from one host to another...

            Here's the story: Currently reside on 1and1.com with YAF on MSSQL. We are moving to vB which resides on a VPS on knownhost.com using MySQL. When I try to connect to the 1and1.com MSSQL server it errors because they don't allow remote access to databases. SOOOooo, I signed up for another host separate from those two that allows me a MySQL databse and MSSQL database both in one service package. Now when I do the import it allows it to connect to the MSSQL database and allows me to go through the modules...the problem is each module doesn't fail or succeed the counters on the right side stay 0 all the time.

            What do you think?

            Comment


            • #21
              What I think is what I posted previously. It appears that you are not able to connect to the source server from your vB server. Unfortunately I do not have any more insight than that. Sorry. Hopefully Jerry will be around today to help more with this.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                Well then my question would be aren't all MSSQL database located on an MSSQL server and all MySQL databases located on a MySQL server...if I were transferring from YAF to vB...I would have to go from a MSSQL server to a MySQL server anyway wouldn't I?

                Comment


                • #23
                  Technically you're correct, but we use the word 'server' as an equivalent of the actual machine, instead of just the server software.

                  To your problem: Make sure you're actually connecting to the correct database, and that the YAF database doesn't have a table prefix or similiar.
                  Best Regards
                  Colin Frei

                  Please don't contact me per PM.

                  Comment


                  • #24
                    I will double check the YAF database for a prefix as that could be an issue...but I don't recall it having a prefix. When I pull up database in a third party piece of software it can see the database...so I know the logins are correct.

                    I will check my YAF database for prefixes and similar items...Do you think it would be possible to have MSSQL and MySQL ran on the same server? Like do you think I could get my host to have both on the same server? Would that help in my efforts?

                    Comment


                    • #25
                      The YAF Database does have a prefix of yaf...so I added yaf_ to the prefix line in the impexconfig file. I can connect to the database via a third party program...why can't I through impex?

                      Comment


                      • #26
                        Ok, I need help...we are running out of time on our 1and1.com server and don't want to pay for another 3 months...What am I doing wrong??? Can someone help transfer my info over? I am unsure what to do now...

                        Comment


                        • #27
                          What if I converted my MSSQL to a MySQL database and then installed that onto my MySQL database server...would that work?

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X