Announcement

Collapse
No announcement yet.

Problem with charset after import from phpBB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bela-meaad
    replied
    Try this. Edit impex/db_mysql.php and change this line:

    $query_id = $query_type(utf8_encode($query_string), $this->link_id);

    To this:

    $query_id = $query_type($query_string, $this->link_id);

    Then redo the import. Let me know if that works.
    http://www.vbulletin.com/forum/showthread.php?t=220486

    Regards

    Leave a comment:


  • kourou
    started a topic Problem with charset after import from phpBB

    Problem with charset after import from phpBB

    Hello there.

    I'm trying to import data from phpBB but all the characters are wrong. From what i can see on phpmyadmin, MySQL charset is UTF-8 Unicode (utf8) with collation utf8_unicode_ci.

    The database that vBulletin is installed on has latin1_swedish_ci as default collation. I tried to change the default database collation to utf8_unicode_ci and the collation of one table (the one i'm testing on - for example 'forum') to utf8_unicode_ci but the problem still exists.

    Something important: When importing the data from the old forum (phpBB), impEx seems to read them correctly, as the characters appear normally on impEx procedure. I guess it has problems trying to to 'copy' the data to the vBulletin tables.

    Thanks in advance and I look forward to your answer.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X