Announcement

Collapse
No announcement yet.

Can't get back into the import system...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get back into the import system...

    Hello, my forum is up and running with everything imported. But I guess I forgot to run the cleaner. So, I went back to do that, and now after I click the Import link on admincp and enter my license number.. the screen just sits there and flashes and never opens the import screen. Is it too late to run the cleaner? Or is this problem something else? I never uninstalled the impex program... Nor changed the config program, so I'm lost as to why this error is happening.
    Thanks!
    Andrew

  • #2
    What cleaner exactly and what are you attemting to do?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      cleaner.php I read it fixes some of the phrasing that is different from ikonboard to vBulletin? like the switch of [] <> tags to fit the new forum. Or am I missunderstanding the tool?

      Comment


      • #4
        You run that directly, i.e.,

        http://www.yoursite.cpm/forums/impex/tools/cleaner.php

        You need to edit it first:

        http://www.vbulletin.com/docs/html/main/impex_cleaner
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Okay- I've figured that out. Thanks,
          Then I went to rebuild the post cache and it does the same thing as going into the import menu. It sits and flashes like it is reloading, and every now and again, I can see "building post cache N/A" That's definatly not what I've seen before when running this tool.
          Andrew

          Comment


          • #6
            Why are you rebuilding the post cache? I'm not sure what this has to do with the original question.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Uhm, because the instructions say to???


              Cleaner.php cleaner.php is located in the impex/tools/ directory.

              ImpEx parses out as much HTML and incorrect BB code as it can find, though there can sometimes be unexpected HTML or codes in the posts.

              To remove this you will need to use cleaner.php, the basic principle is that is matches one string and replaces it for another, or a blank to just delete the original string.

              Once cleaner has been run successfully you must rebuild the Rebuild Post Cache in the AdminCP > Maintenance > Update Counters


              The file itself has many comments and instructions though as an example, if I have the post :

              Comment


              • #8
                Okay. Did you run it until it finished? If not, what happened exactly?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  When attempting to start the rebuild post cache, it sits and flashes like the page is reloading (Same thing as when I try to go to the import tool via admin CP) every now and again you see a flash of "rebuilding post cache, processing N/A" Then it will flash a few lines like it is working, then back to the reloading of the page... When it does show lines it's working on, it adds 1,2 to the end of the processed item, I don't recall seeing that before. It does "stop" but I don't know if it actually finishes. I don't know if the problem is related to entering the import tool, and it sitting and reloading too (but never letting me in) but it seems worth mentioning.
                  Andrew

                  Comment


                  • #10
                    Assuming it did finish do you have any outstanding issues?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Well, I guess it's minor but what I was trying to do is remove "\" that was added to peoples signatures. But when I put "\" in the find slot and nothing in the replace slot (to have them deleted) I get
                      error Parse error: parse error, unexpected '\"', expecting ')' in ********/forums/impex/tools/cleaner.php on line 51
                      So, I tried using the code for "\" (%5C%22) and it showed the signatures were being gone through. Then I "ran" (assuming it worked) the rebuild mentioned above. But the "\" are still there.

                      Comment


                      • #12
                        The parse error indicates you have a typo in your cleaner.php file. Post the exact edit you made.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Code:
                          // Set to true to run, and false when done, or remove this script (and all of impex when finished).
                          $active                = true;
                          
                          // Set true or false as to the data you want to clean
                          $do_posts            = false;
                          $do_sigs            = true;
                          $do_thread_titles    = false;
                          $do_pm_text            = false;
                          $do_pm_text_title    = false;
                          ########################################
                          
                          # Replace 'Find me' and "Replace with me" with the strings  you want replaced i.e
                          # "<b>"            => "[b]"
                          # "<blockquote>"     => "[quote]"
                          # add as many elements to the array as needed
                          
                          // BACK UP YOUR DATABASE
                          $replacer = array(
                                      "\"    => ""
                          );
                          Once I changed "\" to "%5C%22" it ran fine. So by that, I made the assumption that I didn't have a typo anywhere... It just didn't like finding the "\" character.
                          Thanks for looking into this :-)

                          Comment


                          • #14
                            Is that enough? Or do you need the whole file?

                            Comment


                            • #15
                              I thought you said:

                              I changed "\" to "%5C%22" it ran fine
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X