Announcement

Collapse
No announcement yet.

Database lost connection to source

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Marco van Herwaarden
    replied
    Please do not attach copyrighted files (including your license-id). If needed open a support ticket please.

    Leave a comment:


  • SOL_R
    replied
    Jerry, I played with the impex files for eve a bit. I changed the case to lower case for the table names. Here it is. Would you check it and make sure I got it right please. That is the eve 000.php file. I didn't see the table names any where else, but your the expert and would know better than me.


    Thanks


    Richard
    Last edited by Marco van Herwaarden; Thu 28 Dec '06, 7:22am.

    Leave a comment:


  • SOL_R
    replied
    Hi Jerry! Any luck with changing the converter?


    Thanks


    Richard

    Leave a comment:


  • SOL_R
    replied
    Okay............the table names are all lower case but the field names are all upper.


    (sighs)


    Thanks

    Richard

    Leave a comment:


  • Jerry
    replied
    Are all the field names within the tables lower or uppercase ?

    Leave a comment:


  • Jerry
    replied
    Good old windows destroying the case again ........

    I'll update ImpEx and eve for that now.

    Leave a comment:


  • SOL_R
    replied
    Originally posted by Jerry View Post
    Nope, do you have the correct case ?

    Are the table names in MySQL upper or lower case ?
    I have the right case for the name of the database. The table names are all in lower case but when impex runs it shows it cant find them in (all in upper case)

    Is that the problem? If so how do we fix that?


    Thanks so much for your help Jerry!

    Richard

    Leave a comment:


  • Jerry
    replied
    Originally posted by SOL_R View Post
    Hi Jerry, its named infopop. That doesnt fall in reserved words does it?


    Richard
    Nope, do you have the correct case ?

    Are the table names in MySQL upper or lower case ?

    Leave a comment:


  • SOL_R
    replied
    Hi Jerry, its named infopop. That doesnt fall in reserved words does it?


    Richard

    Leave a comment:


  • Jerry
    replied
    Well its selecting, though thoses tables arn't in the Infopop database it would seem.

    What did you name the databases in phpMyAdmin ?

    There will be no table prefix with eve.

    Leave a comment:


  • SOL_R
    replied
    Hi Jerry I dont know if you want the whole page but


    Remove ImpEx once import is complete and final
    ImpEx build version : 1.74

    Database cleanup & restart ||| Online manual
    Using ImpExConfig.php for target config.

    Altering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers. This is needed during the import process for maintaining refrences between the tables during an import. If you have large tables (i.e. lots of posts) this can take some time. They will also be left after the import if you need to link back to the origional vB userid.
    moderator - importmoderatorid OK
    usergroup - importusergroupid OK
    ranks - importrankid OK
    poll - importpollid OK
    forum - importforumid OK
    forum - importcategoryid OK
    user - importuserid OK
    style - importstyleid OK
    thread - importthreadid OK
    post - importthreadid OK
    thread - importforumid OK
    smilie - importsmilieid OK
    pmtext - importpmid OK
    avatar - importavatarid OK
    customavatar - importcustomavatarid OK
    customprofilepic - importcustomprofilepicid OK
    post - importpostid OK
    attachment - importattachmentid OK
    pm - importpmid OK
    usernote - importusernoteid OK
    phrase - importphraseid OK
    subscription - importsubscriptionid OK
    subscriptionlog - importsubscriptionlogid OK

    Valid found tables :


    Possiablly custom tables or incorrect prefix :

    CACHE NOT found.
    CONTENT_ISLANDS NOT found.
    CURRENT_DB_VERSION NOT found.
    C_CATEGORIES NOT found.
    C_ITEMS NOT found.
    C_REVISIONS NOT found.
    C_REVISION_LOGS NOT found.
    C_STAGING NOT found.
    C_TAGS NOT found.
    C_TAG_TO_REV_JOIN NOT found.
    DATABASE_INFO NOT found.
    FORUMS NOT found.
    GROUP_TOPICS NOT found.
    GROUP_TOPIC_EVENTS NOT found.
    GROUP_TOPIC_PARTICIPANTS NOT found.
    IP_ALBUMS NOT found.
    IP_ALBUM_IMAGES NOT found.
    IP_ARCHIVED_TOPICS NOT found.
    IP_A_ALBUM NOT found.
    IP_A_ALBUM_IMAGE NOT found.
    IP_BANNED_USERS NOT found.
    IP_CAT_CATEGORY NOT found.
    IP_CAT_RESOURCE_CATEGORY NOT found.
    IP_CHAT_TOPICS NOT found.
    IP_CHAT_TOPIC_MESSAGES NOT found.
    IP_CHAT_TOPIC_UNMOD_QUEUE NOT found.
    IP_CLONE_SOURCE_AND_DEST NOT found.
    IP_CONTENT_SUBSCRIPTIONS NOT found.
    IP_CUSTOM_CODES NOT found.
    IP_CUSTOM_PROFILE_FIELDS NOT found.
    IP_C_CONTENT NOT found.
    IP_C_CONTENT_ISLAND NOT found.
    IP_C_CONTENT_LOOKUP NOT found.
    IP_C_CONTENT_REPORT NOT found.
    IP_C_CONTENT_TYPE NOT found.
    IP_C_EXTENDED_DATA NOT found.
    IP_C_GUEST_USER NOT found.
    IP_C_MODERATED_CONTENT NOT found.
    IP_C_RATED_CONTENT NOT found.
    IP_C_UPLOAD NOT found.
    IP_C_USER_FAVORITE NOT found.
    IP_C_USER_INTEREST_LOG NOT found.
    IP_DISPLAY_OPTIONS NOT found.
    IP_DISPLAY_RESOURCES NOT found.
    IP_DISPLAY_RES_ASSOCIATIONS NOT found.
    IP_EVENT_LOG NOT found.
    IP_F_FORUM NOT found.
    IP_F_FORUM_ACCEPTED_POST_TYPE NOT found.
    IP_F_FORUM_ATTACHMENT_RULE NOT found.
    IP_F_FORUM_MOD_CONTENT_TYPE NOT found.
    IP_F_FORUM_STATS NOT found.
    IP_F_FORUM_TOPIC NOT found.
    IP_GROUPS NOT found.
    IP_GROUP_USERS NOT found.
    IP_HIGHLIGHTED_TOPICS NOT found.
    IP_IGNORED_USERS NOT found.
    IP_IM_ACTIVE_MENUS NOT found.
    IP_IM_PARTICIPANTS NOT found.
    IP_KARMA_LEVELS NOT found.
    IP_MESSAGE_ALERTS NOT found.
    IP_PERMISSIONS NOT found.
    IP_PREMIUM_GROUP_SETTINGS NOT found.
    IP_PRIVATE_WEB_IDIRECTORIES NOT found.
    IP_PROFILES NOT found.
    IP_PT_PRIVATE_TOPIC NOT found.
    IP_PT_PRIVATE_TOPIC_PARTICIPANT NOT found.
    IP_P_POLL NOT found.
    IP_P_POLL_ANSWER NOT found.
    IP_P_POLL_QUESTION NOT found.
    IP_P_POLL_RESPONSE NOT found.
    IP_RESOURCES NOT found.
    IP_RIGHTS NOT found.
    IP_RW_LOCKS2 NOT found.
    IP_SESSION_ACTIVITY NOT found.
    IP_SETTINGS NOT found.
    IP_SS_IMAGE_DIMENSIONS NOT found.
    IP_STATISTICS NOT found.
    IP_STREET_ADDRESSES NOT found.
    IP_STYLE_SETS NOT found.
    IP_STYLE_SETTINGS NOT found.
    IP_TEMPLATE_FILES NOT found.
    IP_TEMPLATE_PAGE_TYPES NOT found.
    IP_TEMPLATE_SETS NOT found.
    IP_TEMPLATE_SET_USAGE NOT found.
    IP_TEMPLATE_SUPPORT_INFO NOT found.
    IP_TOPICS NOT found.
    IP_T_ARCHIVED_MESSAGE NOT found.
    IP_T_ARCHIVED_TOPIC NOT found.
    IP_T_MESSAGE NOT found.
    IP_T_TOPIC NOT found.
    IP_T_TOPIC_STATS NOT found.
    IP_UNCONFIRMED_USERS NOT found.
    IP_USERS NOT found.
    IP_USER_CONTACT_INFO NOT found.
    IP_USER_FAVORITES NOT found.
    IP_USER_RESOURCE_INFO NOT found.
    IP_WORDLETS NOT found.
    IP_WORDLET_SETS NOT found.
    POLLS NOT found.
    UNMOD_MESSAGE_QUEUE NOT found.
    UPLOADS NOT found.
    URL_LOOKUP NOT found.
    USER_INFO NOT found.
    IP_C_SEARCH_EVENT NOT found.
    IP_T_MESSAGE_TO_DELETE NOT found.
    IP_USER_STATS NOT found.Failed Check database permissions and connection, or table prefix to ensure its correct.
    Once you have finished these modules follow these instructions to complete the import


    that is the error I get


    Thanks!

    Richard

    P/S I have tried it with the IP_ table prefix and without it as well.
    Last edited by SOL_R; Wed 20 Dec '06, 9:32am.

    Leave a comment:


  • Jerry
    replied
    Yes the XML file is not needed for standalone.

    What is the actuall error ? Does it look like a MySQL error or is it ImpEx saying it can't connect, or find etc ?

    Can't you paste the text your are getting here.

    Leave a comment:


  • SOL_R
    replied
    Originally posted by Jerry View Post
    Try using the root user and password for the source as well, then permissions arn't going to be an issue.
    Yes I just tried that again, also I checked the permissions and they are correct.

    Originally posted by Jerry View Post
    Can you see both databases : smartb and Infopop when browsing phpMyAdmin ?

    Yes they both are there.

    I didnt realize how much fun this would be, I am sure once we get to work things will be fine.

    One thing I didn't do was move the xml file but that pertains to the acp correct? Since this is standalone its not needed?

    Richard

    Leave a comment:


  • Jerry
    replied
    Try using the root user and password for the source as well, then permissions arn't going to be an issue.

    Can you see both databases : smartb and Infopop when browsing phpMyAdmin ?

    Leave a comment:


  • SOL_R
    replied
    Hi Jerry! That worked great! Thank you so much.

    I put the impex folder into the htdocs folder and then I have the config file as such

    # For mysqli enter mysql
    $impexconfig['target']['databasetype'] = 'mysql';
    $impexconfig['target']['server'] = 'localhost';
    $impexconfig['target']['user'] = 'root';
    $impexconfig['target']['password'] = 'XXXXX';
    $impexconfig['target']['database'] = 'smartb';
    $impexconfig['target']['tableprefix'] = 'vb_';


    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to true.
    # If the source data is NOT stored in a database, set 'sourceexists' to false

    $impexconfig['sourceexists'] = true;

    # mysql / mssql
    $impexconfig['source']['databasetype'] = 'mysql';
    $impexconfig['source']['server'] = 'localhost';
    $impexconfig['source']['user'] = 'XXXX';
    $impexconfig['source']['password'] = 'XXXXXX';
    $impexconfig['source']['database'] = 'Infopop';
    $impexconfig['source']['tableprefix'] = '';

    It seems to be finding the target but the source is coming up with it cant find or connect to it.

    Am I missing something here? Do I need to edit anything else besides the config?

    Thanks again!~

    Richard

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X