Announcement

Collapse
No announcement yet.

Problem importing a WoWBB 1.7 forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem importing a WoWBB 1.7 forum

    Good morning Jerry!

    Before I start, I'd just like to compliment you and the whole crew on a great product. It's a bit twisty at times, but the documentation is excellent.

    'K, here we go:

    Last night I configured and installed a clean vBulletin 3.6.2, I then configured and installed Impex with just the folder for wowBB and index in the impex/systems directory.

    So I have a clean vBulletin 3.6.2 importing from WoWBB 1.7.

    Everything seemed to go well until I got to "polls" It imported about 5 and then flashed to a blank import screen (like it does as it changes to another batch) for "polls" and just hung there.

    After waiting for quite a while (10-15 min?) I went through the options and eventually reset the whole import, dumping the data and starting from scratch. Same thing happened, and I couldn't go to any other part of the process (I know you said not to page back, but I gave it a shot out of deperation, but always ended back on the blank "poll" import screen).

    So I dumped the import again and this time I imported everything BUT the polls... Did them last . Then I striped the import id tags from the DB and ran through the post import steps in the Admin cp (Forum Manager Save Display Order etc) as outlined in the Impex manual.

    Here comes the wierd part. All the forums, threads, posts seem to be there, and all the users seem to be in the DB, but they are all banned for life? I checked and they didn't get put in an import usergroup. But when I looked under the custom usergroups I found that all the groups seemed to have the "Not a banned group" value set to "No". Ah-ha! So I set them to "Yes". But... everyone is still banned? Ok... At this point I think I need some guidance?

    I've got the original state of the clean vBulletin DB backed up, as well as the entire httpdocs folder from just before the import, so I can definitely roll everything back, and this is just a trial/dry run that has zero impact on my production WoWBB forum.

    Any assistance in figuring this out would be greatly appreciated! TIA

    James

  • #2
    First things with the banned bit. Have you tried deleting the usergroup they are in to move them to the Registered group ?

    As for Polls, if it returns to the main import screen with the modules, then the poll module itself should be done ? I take it the polls are missing or their failed ?
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      The weird thing is that there WAS no overarching user group that everyone is in? When I look at an individual user I'm seeing that they aren't assigned to anything except a Primary Usergroup. They are not assigned to ANY "Additional Usergroups" such as Registered, Unregistered etc.

      With respect to the Polls, once I ran the Polls process it never DID go back to the main screen, that was the problem I would just go to the blank screen like it was getting ready to run another set of polls and hang there. No error message, nothing. The final time through I just did the polls last and then used the "Database cleanup & Restart" link to get out of the blank Poll import screen and then selected "Remove importids" so that I could see what DID import.

      When I went and looked at the result, I DID see polls there but every user post has "Imported Post" showing up and is missing their avatar and profile info.

      Obviously the first place to look is the part that didn't work right, the Polls?

      I can start from scratch and use a different copy of the WoWBB DB? Do you know if I should be expecting to see problems coming from 1.7?

      Thanks again for any help you can provide...

      James

      Comment


      • #4
        Well the importer was written for 1.63 so I can't see the schema changing that much that the usergroups would fail, I take it in module 003 that the usergroups all imported fine or not?

        ImpEx should import and create the wowBB usergroups in vBulletin, then import the users into those groups, as they were in the source board.

        I found the poll issue, download ImpEx again and upload and overwrite:

        impex/systems/wowBB/008.php
        I wrote ImpEx.

        Blog | Me

        Comment


        • #5
          Ok... I rolled everything back and re-ran the import. Polls ran just fine THAT one appears to be fixed with the new file.

          Everyone is still banned however. I did find a reference to changing the usergroup properties to let them be listed on the memberlist and now everyone shows up... But everyone is also still banned for life , even after I went into the usergroup manager and changed the group so that "Not a member of a banned group" is Yes. Also all posts are still listed as "Imported Post" in the threads, even after I ran the Clean-up and selected "Remove importids".

          There was no group created to hold all imported users, they are all just in the original groups they were in on WoWBB.

          Avatars are also not associated with their users, I DID copy them over manually, so I know the files are there.
          Last edited by Tigratrus; Thu 26 Oct '06, 7:04pm. Reason: additional info

          Comment


          • #6
            When I say the groups are created, I mean the wowBB ones that are created in vBulletin by ImpEx.

            You don't have to copy the avatars to any where as long as ImpEx can read from the source.

            Is you browse a user in the admincp does it say they are in the banned group ?
            I wrote ImpEx.

            Blog | Me

            Comment


            • #7
              There were no users listed in the banned group. When I looked at each of the WoWBB groups that were created they all had the value for "This Usergroup is not a 'Banned' Group" set to "No", I changed all the groups so that they had "yes" instead, but the user I was using as a test account was still unable to access posts "Banned for life" Do we need to move all users out of the groups created from WoWBB and into new groups?

              Is there a way to remove the "Imported Post" lable on all posts? I ran the Clean-up and selected "Remove importids", but it's still there?

              For the avatars is the path that I need to put in the path to the WoWBB forum? If so what should I put in if I have WoWBB avatars in httpdocs/forums/images/avatars. And (if it matters) vBulletin is in httpdocs/vbulletin/images/avatars?

              James

              Comment


              • #8
                Jerry,

                I've been playing around with the import some more, and getting all the users out of the groups that were imported from the WoWBB forum did indeed fix the Banned user issue. I certainly understand vBulletin user groups much better now .

                Remaining issues:

                1. I still have all posts showing up as "imported post" even after I ran the Clean-up and selected "Remove importids".

                2. Avatars still are not importing. In the database the avatarid is set to 0 even for users that SHOULD have an avatar? When asked for the full path (where images/avatars is located); if given an install path of httpdocs/vbulletin/images/avatars, what should be entered?

                3. Custom user fields are not being imported.

                In reflection, I think the custom user fields were a new feature in WoWBB 1.7? Perhaps issues #2 & #3 are related and are being caused by the DB changes to support custom user fields?

                Comment


                • #9
                  If you have removed the import id's you have finalised the import and ImpEx will not be able to clear anything out, you will have to redo the import.

                  The "imported post" is a title added by ImpEx, to remove that you can run this SQL :

                  Code:
                  UPDATE post SET title='' WHERE title='imported post'
                  Nothing custom is imported only default values.
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    Thanks for the SQL fix for the post title, that should solve that one.

                    What about the avatars? They aren't importing... I looked in the User table and avatarid is set to 0?

                    I understand from a few other pots on here that it's looking for the path to the WoWBB avatar folder? Are we talking URL here? Or does it need to be locally installed? I'm having problems getting a good backup/restore of the live WoWBB DB, but I ran a test import after shutting down the live forum and that seemed to work fine with the exception of the avatars...

                    Comment


                    • #11
                      It's a local path to the avatars, PHP on the server that ImpEx is running on needs read access to them.
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #12
                        1. I can put them in a local folder no problem... Is the avatarid not getting set if it can't find the files?

                        2. Can you give me an example path as it should be entered if the avatars are in:

                        httpdocs/forum/images/avatars

                        Would that be a full system path like:

                        c:\Inetpub\vhosts\Ikeafans.biz\httpdocs\forum\images\avatars

                        The verbiage in the tool is vague on whether it's looking for the "forum" or the avatars directory?
                        Last edited by Tigratrus; Mon 30 Oct '06, 12:18pm.

                        Comment


                        • #13
                          1)

                          If it can't find the files, yes that will be 0 as the avatar import will fail.

                          2)
                          Its looking for the full local path to the source forum as the avatar information in the database is stored thus :

                          images/avatars/2.jpg

                          So if the full path to one of the images is :

                          /home/jerry/www/sourceforum/images/avatars/2.jpg

                          Then enter:

                          /home/jerry/www/sourceforum/
                          I wrote ImpEx.

                          Blog | Me

                          Comment


                          • #14
                            Excellent. I'll give the import another try as soon as I can get my partner to stop playing with adding a left hand column

                            Thanks for the responses!

                            Comment


                            • #15
                              Avatars still not importing

                              Total abject failure on importing the avatars. They just don't do anything at all. No files are imported, no entries are made in the database.

                              I thought perhaps I could work around it by setting the system to store them in the Filesystem, copying them in and then updating the table(s) via SQL, but the customavatar table has way too much unique info about each avatar. AARRRRGH!

                              ::sigh::

                              This is my LAST stumbling block... And it seems like the problem is either being caused by DB changes in WoWBB 1.7 from 1.65 OR I'm still putting the path in wrong. I've TRIED a LOT of possible paths (at 15-20 min an import each). I'm just going to have to ask for a flat out answer if possible:

                              I'm on an Windows/IIS server, the path to the WoWBB avatars is:

                              C:\Inetpub\vhosts\ikeafans.biz\httpdocs\forums\images\avatars

                              For relative pathing concerns, vbulletin is installed in:

                              C:\Inetpub\vhosts\ikeafans.biz\httpdocs\vbulletin

                              What should I be putting in? I feel like an idiot that I just can't get the Avatars to import, it takes so long to try it each time, and there's no real error message, just a lack of anything coming in. What part of the ImpEx process would be doing the actual importing of the avatars? The Import User? If I re-run the User Import will it try to bring in the avatars again or will it completely skip over users that already have an entry in the User Table based on importuserid?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X