Announcement

Collapse
No announcement yet.

Installing & Impex PHP error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing & Impex PHP error

    I have the dreaded stack overflow error migrating posts from SMF to 3.6.2. It happens at the exact same spot every time, somewhere between 132,000 and the 134,000th post. I can see the post run before this one, but I can't figure out the next post in sequence so I can kill it to keep on rolling.

    Stack overflow is usually due to something funky in the post....so how can I drill down to find the next post its importing??

    VB 3.6.2
    W2k3
    IIS 6.0
    PHP 5.1.6
    MySQL 5.0.26
    Zend 3.01

  • #2
    What dreaded stack overflow?

    Comment


    • #3
      "PHP has encountered a stack overflow" Completely stops the post import. Just need to hurdle that bad post record somehow.

      Usually a result of ISAPI php on Win platform when there is a jacked up post.

      Comment


      • #4
        Thats the entire error message?

        Comment


        • #5
          Exactly.

          I cant figure out how to identify what post is causing it. Other than that, we are ready to be a fully operational VB board.

          Comment


          • #6
            Is there a way, looking at the import script, to determine which post is causing the break?

            Comment


            • #7
              Not really.


              This may be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

              ini_set('memory_limit', 32 * 1024 * 1024);
              ini_set("max_execution_time", "480");
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                Not really.


                This may be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                ini_set('memory_limit', 32 * 1024 * 1024);
                ini_set("max_execution_time", "480");


                This did not help, just tried to reimport again. Stops at the very same spot.

                Course, I started the import from where it left off from inside the admin area. Did not see the php error this time, it just stopped. executed under 60 seconds to that point.

                Comment


                • #9
                  Can't I get the query somehow, and then run it...and then look at the records around the mark where it fails?

                  That seems like an option?

                  I am rerunning it from scratch now.

                  Comment


                  • #10
                    Moving this to the Import forum so Jerry will see it.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Importing 100 Posts

                      From : 132900 :: To : 133000

                      81.25% Post -> Re: I couldn't believe it PHP has encountered a Stack overflow
                      81.25%
                      Post -> Re: Onterrio and NFL Hypocrisy
                      81.25% Post -> Re: Bennett=Totally healthy, fast!!!
                      81.25% Post -> Re: football card
                      81.25% Post -> Re: Bennett=Totally healthy, fast!!!
                      81.25% Post -> Re: I couldn't believe it

                      Comment


                      • #12
                        I've added the source post id to the display for SMF now, it will display to the left of the % so you can track the rogue source post.

                        You'll need to download ImpEx again and upload and overwrite the file :

                        impex/systems/smf/007.php
                        I wrote ImpEx.

                        Blog | Me

                        Comment


                        • #13
                          Originally posted by Jerry View Post
                          I've added the source post id to the display for SMF now, it will display to the left of the % so you can track the rogue source post.

                          You'll need to download ImpEx again and upload and overwrite the file :

                          impex/systems/smf/007.php
                          That was what I needed, thanks. Found the post that was the issue and things are moving again. Great support, thanks

                          Comment

                          Loading...
                          Working...
                          X