Announcement

Collapse
No announcement yet.

phpBB to vB import problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • phpBB to vB import problems

    Hi:

    I've been trying to solve this problem for a while now, so I thought someone here could provide some insight.

    I've been trying to import from a phpoBB 2.0.11 board into a vB 3.6 board (It worked fine last time I tried importing, that was with 3.5). When I attempt to import the users into vB, I am confronted with the following error:

    Code:
    ImpEx Database errormysql error: Invalid SQL: SELECT profilefieldid FROM vb_profilefield WHERE title = 'Occupation'
    
    mysql error: Unknown column 'title' in 'where clause'
    
    mysql error number: 1054
    
    Date: Tuesday 03rd 2006f October 2006 10:35:00 PM
    I noticed that the ImpEx menu for a target board listed vB 3.5 as an option, not 3.6. I'm not sure if this is an issue or not, but as far as I know I have the latest version of Impex (just downloaded and uploaded).

    Any help would be appreciated, thanks.

    Kyzyl Herzog

    UPDATE: So as far as I can see it's using a backdated version of the database class, so it has incorrect data about the structure of my DB. What I can't figure out is (a) why, (b) why can't I select 3.6 in the ImpEx target menu, and (c) Why does it still happen if I alter the code to only include ImpExDatabase_360?

    UPDATE2: Most of what was said above can be disregarded. Because of a DNS issue, I was actually going to the wrong code. But now, when I go to the admin panel->import->import, I get promted for my customer ID. When I input it, I'm told it was 'successful', and redirected to /impex/index.php, which is just giving me a blank page. Yes it exists, no there isn't another index.(html|php|asp|etc...), and no the php file is not blank.
    Last edited by kyzyl; Tue 3 Oct '06, 11:10pm.

  • #2
    With every import you need to ensure you are using the very latest ImpEx and that you have deleted the session before running a second import, also if it is a merge import that you have removed the import id's as well.
    I wrote ImpEx.

    Blog | Me

    Comment


    • #3
      As I said, I just downloaded the impex files from the members area. I've removed the importids, removed the session, and removed previously imported data even, several times. I'm past the error in the import itself, now I can't even get to import page. I reuploaded the files, checked, rechecked and double checked. I even removed the sessions from the DB.

      Unless I'm a complete moron and missed something, I don't know where to go from here.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X