Announcement

Collapse
No announcement yet.

2nd phpBB Import?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2nd phpBB Import?

    I started a forum ages ago using phpBB and then upgraded it to vBulletin. I recently acquired another forum on the same topic (which is phpBB 2.xx) and would like to import it into my current vB database.

    I have configured and uploaded the most recent ImpEx and trying to get this new DB imported. It seems that something from the first import is causing this to fail as I am getting the following SQL syntax errors
    PHP Code:
    ImpEx Database errormysql errorInvalid SQL
                        
    INSERT INTO forums_usergroup
                        
    (
                            
    importusergroupidtitledescription,
                            
    usertitlepasswordexpirespasswordhistory,
                            
    pmquotapmsendmax,
                            
    opentagclosetagcanoverride,
                            
    ispublicgroupforumpermissionspmpermissions,
                            
    calendarpermissionswolpermissionsadminpermissions,
                            
    genericpermissionsgenericoptionsattachlimit,
                            
    avatarmaxwidthavatarmaxheightavatarmaxsize,
                            
    profilepicmaxwidthprofilepicmaxheightprofilepicmaxsize
                        
    )
                        
    VALUES
                        
    (
                            
    '69',
                            
    'Active Imported Users',
                            
    '',
                            
    '',
                            
    0,
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    '',
                            
    ''
                        
    )
                    

    mysql errorDuplicate entry '0' for key 1

    mysql error number
    1062

    Date
    Saturday 03rd of June 2006 06:17:12 AM
    Database
    XYZ_travel
    MySQL error

    If I try to run the remove import IDs option here is the error I get
    PHP Code:
    ImpEx Database errormysql errorInvalid SQLDELETE FROM datastore WHERE title='ImpExSession';

    mysql errorTable 'ityt_travel.datastore' doesn't exist

    mysql error number: 1146

    Date: Saturday 03rd of June 2006 06:26:47 AM
    Database: XYZ_travel
    MySQL error: Table '
    ityt_travel.datastore' doesn't exist 
    What should I do so I can get a clean import?

    Thanks in advance,

    Andy
    sigpic

  • #2
    Make sure to run the 'remove import IDs' function before you do anything else, and to back up.
    Make sure you have the forum prefix set correctly for the target database.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      I have backed up (using mysqlhotcopy) and have run the 'remove import IDs' comman first thing.

      Here is the link I use to do that
      /impex/help.php?action=delids

      When I do that (as stated above) I get the following error:
      ImpEx Database errormysql error: Invalid SQL: DELETE FROM datastore WHERE title='ImpExSession';

      mysql error: Table 'XYZ_travel.datastore' doesn't exist

      mysql error number: 1146

      Date: Saturday 03rd of June 2006 06:49:42 AM
      Database: ityt_travel
      MySQL error: Table 'XYZ_travel.datastore' doesn't exist
      It seems that a table from the previous import does not exist anymore.

      What should I do next?
      sigpic

      Comment


      • #4
        That's a default vBulletin table, and has to exist for your board to work.
        Are you using a table prefix on your vBulletin forum?
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Originally posted by Colin F View Post
          That's a default vBulletin table, and has to exist for your board to work.
          Are you using a table prefix on your vBulletin forum?
          DOoooh!! You were right, I did not have the table prfix set in ImpExConfig.php. After correcting the issue I was able to use the 'databse cleanup and restart' function to remove import ids. Then I was presented with the page to select the source data type and then destination. After selecting phpbb and moving on to the next page (everything seemed fine). Then when I run module 001 (Check and update database) I get the following:
          ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
          moderator - importmoderatorid Completed
          usergroup - importusergroupid Completed
          ranks - importrankid Completed
          poll - importpollid Completed
          forum - importforumid Completed
          forum - importcategoryid Completed
          user - importuserid Completed
          style - importstyleid Completed
          thread - importthreadid Completed
          post - importthreadid Completed
          thread - importforumid Completed
          smilie - importsmilieid Completed
          pmtext - importpmid Completed
          avatar - importavatarid Completed
          customavatar - importcustomavatarid Completed
          customprofilepic - importcustomprofilepicid Completed
          post - importpostid Completed
          attachment - importattachmentid Completed
          pm - importpmid Completed
          usernote - importusernoteid Completed

          Then there is an error box with the following info:
          ImpEx Database errormysql error: Invalid SQL:
          INSERT INTO forums_usergroup
          (
          importusergroupid, title, description,
          usertitle, passwordexpires, passwordhistory,
          pmquota, pmsendmax,
          opentag, closetag, canoverride,
          ispublicgroup, forumpermissions, pmpermissions,
          calendarpermissions, wolpermissions, adminpermissions,
          genericpermissions, genericoptions, attachlimit,
          avatarmaxwidth, avatarmaxheight, avatarmaxsize,
          profilepicmaxwidth, profilepicmaxheight, profilepicmaxsize
          )
          VALUES
          (
          '69',
          'Active Imported Users',
          '',
          '',
          0,
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          '',
          ''
          )

          mysql error: Duplicate entry '0' for key 1
          mysql error number: 1062
          Date: Sunday 04th of June 2006 02:10:55 AM
          Database: XYZ_travel
          MySQL error:
          So making progress, but what do I try now?

          Thanks again for your help!

          Andy
          sigpic

          Comment


          • #6
            It seems like some of the tables are not setup right. I have been comparing them to a DB that never had an import and when I change the Default from O to empty and then under extra I set that to auto-increment then I can get through things. So I think I will be able to get everything done.

            Is there anything I can do to make sure all my tables are "just right" like fix unique ids from the maintenance with the schema.sql file in place. If would be nice to know that everything is correct (I have no idea why that would be different???)
            sigpic

            Comment


            • #7
              Just as an FYI - I did a fresh install of vB3.5.4 and then imported the old DB that had been used for both of the old phpBB installs (and had all kinds of hacks applied). Now I have all the posts in a clean fresh install of vB and it's time to clean up the DB, members and get this community moving in the right direction.

              Thanks for the great software!
              sigpic

              Comment


              • #8
                I'm guessing there was an existing import done on the vBulletin before you started and that usergroup already existed or the auto_inc was out
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X