Announcement

Collapse
No announcement yet.

Error when trying to run Impex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERuiz
    replied
    Note:
    The web publishing folder is usually called public_html, www or htdocs and is located within your home directory. If you are unsure of where to find your own web publishing folder, your host will be able to help you. Upload the ImpEx folder inside the installed vBulletin version 3 folder. Like public_html/forum/impex/
    This if from the online manual. It can cause confusion.

    Leave a comment:


  • Jerry
    replied
    ImpEx is designed to sit on the same level as admincp/

    Leave a comment:


  • ERuiz
    replied
    Ok, I figured out what was the problem. I had placed the /impex folder on the forum ROOT folder and it would not run from here. I would get the error. Then I moved the /impex folder to the /forum/admincp folder. When I tried to run it from the AdminCP, the Import link would not work because it was pointing to /forum/impex/index.php

    So I had to edit the .xml file which was included with the zip file, so that it would point to /forum/admincp/impex/index.php

    Uploaded the .xml file, refreshed the AdminCP and when I clicked on import, it worked. Now I have the options for importing SMF into VB.

    I had installed to the forum root folder, because it says so in the online manual.

    Leave a comment:


  • ERuiz
    replied
    Originally posted by Jerry
    Update the ImpExConfig.php with your target database information, it looks like ImpEx isn't reading your vBulletin's config for some reason.
    Tried it and still the same error. When I click on Import, it asks for the Customer Number. Once I enter it and click ok, it says "successful" and then when it refreshes the page, it gives me the error.

    I have a question. Does the /impex folder go to the forum ROOT folder or does it go to the /forum/admincp folder? In the installation manual, it mentions both places.
    Last edited by ERuiz; Wed 8 Mar '06, 8:15pm.

    Leave a comment:


  • Jerry
    replied
    Update the ImpExConfig.php with your target database information, it looks like ImpEx isn't reading your vBulletin's config for some reason.

    Leave a comment:


  • ERuiz
    started a topic Error when trying to run Impex

    Error when trying to run Impex

    I have followed the instructions on this website on how to install and run Impex but I keep getting the following error:
    ImpEx Database errormysql error: Invalid SQL: SELECT title, data FROM vb3_datastore WHERE title = 'ImpExSession'

    mysql error: No database selected

    mysql error number: 1046

    Date: Wednesday 08th 2006f March 2006 09:15:55 PM
    Database: joinapr_website
    MySQL error: No database selected
    Here is ImpExConfig.php settings:

    Code:
    <?php
    #################################################################### |;
    # vBulletin  - Licence Number VBF6E3FBA7
    # ---------------------------------------------------------------- # |;
    # Copyright ©2000–2006 Jelsoft Enterprises Ltd. All Rights Reserved. |;
    # This file may not be redistributed in whole or significant part. # |;
    # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # |;
    # http://www.vbulletin.com | http://www.vbulletin.com/license.html # |;
    #################################################################### |;
    
    # The following settings allow ImpEx to connect to the vBulletin 3
    # database into which you will be importing data.
    
    # If impex is installed in vBulletin you can ignore the target details
    # as includes/config.php
    
    $impexconfig['target']['databasetype']	= 'mysql';
    $impexconfig['target']['server']		= 'localhost';
    $impexconfig['target']['user']			= 'username';
    $impexconfig['target']['password']		= 'password';
    $impexconfig['target']['database']		= 'vbulletin_forum';
    $impexconfig['target']['tableprefix']	= '';
    
    
    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to TRUE.
    # If the source data is NOT stored in a database, set 'sourceexists' to FALSE
    
    $impexconfig['sourceexists']			= true;
    
    # mysql / mssql
    $impexconfig['source']['databasetype']	= 'mysql';
    $impexconfig['source']['server']		= 'localhost';
    $impexconfig['source']['user']			= 'joinapr_*****';
    $impexconfig['source']['password']		= '********';
    $impexconfig['source']['database']		= 'joinapr_*****';
    $impexconfig['source']['tableprefix']   = 'smf_';
    
    
    # Error logging will log import errors to a database table impexerror
    # for use with support. 
    # Language file is the file of phrases to be used, default is english.
    # pagespeed is the second(s) wait before the page refreshes.
    
    $impexconfig['system']['errorlogging']	= true;
    $impexconfig['system']['language']		= 'impex/impex_language.php';
    $impexconfig['system']['pagespeed']		= 1;
    
    ?>
    I want to import SMF 1.1 RC1 to VB 3.5.4.

    They are both installed on the same database, and share the same dbuser and dbname. All priviledges are assigned to the user.

    I installed the /impex folder to my root forum directory and placed the /includes/xml/cpnav_impex.xml file into the same folder on the server.

    Can anyone help me? Thanks in advance!
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X