Announcement

Collapse
No announcement yet.

Import into test board...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jerry
    replied
    If you have a copy of the source that you are importing from you will need a copy of the source attachments as well.

    The 012 module asks you for the source path.

    ImpEx will import them into vBulletin as long as it has access to them.

    Leave a comment:


  • Jack Black
    replied
    I haven't copied the attachments into the test area...i though that is what Impex would do?
    I will copy them across and retry.

    It isn't specifying any required path....just says "Source file not found"

    EDIT:
    Have now uploaded all but 3 of the attachments...checking allowed extensions...
    Last edited by Jack Black; Fri 3 Mar '06, 3:52pm.

    Leave a comment:


  • Jerry
    replied
    It should error with the path its looking for, have you checked what the local path is and that the files are there ? if you are on a test environment did you copy the attachments over ?

    Leave a comment:


  • Jack Black
    replied
    Tried that. Had no joy. Impex just keeps telling me that source files not found...

    Leave a comment:


  • Jerry
    replied
    They are stored in the file system and the details are stored in the database, just input the path to where they are stored when ImpEx asks and it will do the rest.

    Leave a comment:


  • Jack Black
    replied
    Cheers!

    Everything has gone ok until trying to import the attachments.

    SMF forum has them stored on file system, but file names encrypted. Have gone through and removed the random characters added at the end of filenames, so the true file names are left....have upload them to a seperate folder on the server, and pointed Impex to that folder when it asks for "full path to uploads/attachments folder"....but it just keeps coming "source file not found"
    have redone module about 5 times and every time the same.

    I have set vB up to store attachments on file system before import.

    Any ideas?

    EDIT:
    Scratch that...just found smf_attachments in SMF db.....presumably this means that they are stored in the db as well as on the server?
    I guess i am going to have to quit the import session, delete all imported data and start again?
    Last edited by Jack Black; Fri 3 Mar '06, 2:39pm.

    Leave a comment:


  • Jerry
    replied
    Originally posted by Jack Black
    I already have installed a test vb forum on my site, and was thinking of running impex on that, to see how the process went, before installing what will be the working forum (which will be on a subdomain) and running impex to move from SMF to vb. All i wanted to be sure was that by running impex on the test forum, i wouldn't have problems running it again for the working forum?

    Good plan, that's exactly what is advised to do, set up a test environment where you aren't going to effect a live site, then have a play and a practice.

    Have a read of this :http://www.vbulletin.com/forum/showthread.php?t=116398

    Leave a comment:


  • Jack Black
    replied
    I take it you mean export the sql db from my SMF forum, make a test db and import that, then update config.php to point at that db?

    I already have installed a test vb forum on my site, and was thinking of running impex on that, to see how the process went, before installing what will be the working forum (which will be on a subdomain) and running impex to move from SMF to vb. All i wanted to be sure was that by running impex on the test forum, i wouldn't have problems running it again for the working forum?

    Apologies if i seem rather dense about all this....but it is a steep learning curve for me, and i owe it to my forum users to make sure i get it right!

    Leave a comment:


  • Floris
    replied
    Impex will import all the data and it won't syncronise. You will therefor attempt to import existing users into existing users. Userid's might be changed etc.

    If you want a test forum then the threads and posts and members won't really matter. You're best of to export the .sql and restore it into a new test database. Copy the vb files and update config.php to point to the new database. Then work on the test forum.

    If the test is to see if you can impex data from other forum software into vbulletin you can do the above and then install impex and run impex (on the test forum).

    Once that works I recommend to run impex again, but then from the live site.

    As you;re making a backup prior to doing actual changes like running impex ..you can always revert to the latest working version of your forum if anything goes wrong.

    Leave a comment:


  • Jack Black
    started a topic Import into test board...

    Import into test board...

    If i run impex and import my exsisitng forum into what i intend to use as my test board (which is on a password protected directory) will i have any problems when i later on run the impex again on the exsisting database to import into what will become the main forum?

    Also, in the admin CP, it says "Impex Build Version 1.30"...yet on the thread stuck at the top of this board about how to import it says "latest build 1.31"....Which one is correct?
    Last edited by Jack Black; Fri 3 Mar '06, 4:08am.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X