Announcement

Collapse
No announcement yet.

This is pissing me off!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • This is pissing me off!!

    This is the second day and i still cant install impex. This is a part of it..the immportant one:

    This is my config file:

    '...$impexconfig['target'][''databasetype'] = 'mysql';
    $impexconfig['target']['mysql13.powweb.com'] = 'localhost';
    $impexconfig['target']['username here'] = 'username';
    $impexconfig['target']['password here'] = 'password';
    $impexconfig['target']['database name here'] = 'source';
    $impexconfig['target']['tableprefix'] = '';


    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to TRUE.
    # If the source data is NOT stored in a database, set 'sourceexists' to FALSE

    $impexconfig['sourceexists']['TRUE'] = false;

    # mysql / mssql
    $impexconfig['source']['databasetype'] = 'mysql';
    $impexconfig['source']['mysql13.powweb.com'] = 'localhost';
    $impexconfig['source']['username here'] = 'username';
    $impexconfig['source']['password here'] = 'password';
    $impexconfig['source']['database name here'] = 'source';
    $impexconfig['source']['tableprefix'] = '';..'

    I keep on getting ALL types of errors and i can never get it right. Right now when i go to : http://www.example.com/vb/impex/index.php I get this error:

    Parse error: parse error, unexpected T_STRING, expecting ']' in /www/g/gameonlockco/htdocs/vb/impex/ImpExConfig.php on line 17

    I was wondering if somebody could guide me through the whole installing and importation in this post until everything is done proprly..Ill keep posting the errors and problems im having and u guys just help me..

  • #2
    This error means you have a typo on or before line 17 of your ImpExConfig.php file. Compare it to ImpExConfig.php.new if you need an example of what it should look like.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Alright i fixed the config file but now im getting this error and its not true cause the stuff i put in..is real and right.

      Connection to source server failed. Check username and password.

      what else could cause this error other then the password and username?
      Last edited by Gameonlock.com; Fri 9 Dec '05, 6:21pm.

      Comment


      • #4
        This is what the modified config looks like:

        $impexconfig['target']['databasetype'] = 'mysql';
        $impexconfig['target']['mysql13.powweb.com'] = 'localhost';
        $impexconfig['target']['username here'] = 'username';
        $impexconfig['target']['password of the new database/user'] = 'password';
        $impexconfig['target']['database name here'] = 'vbulletin_forum';
        $impexconfig['target']['tableprefix'] = '';


        # If the system that is being imported from uses a database,
        # enter the details for it here and set 'sourceexists' to TRUE.
        # If the source data is NOT stored in a database, set 'sourceexists' to FALSE

        $impexconfig['sourceexists']['TRUE'] = false;

        # mysql / mssql
        $impexconfig['source']['databasetype'] = 'mysql';
        $impexconfig['source']['mysql13.powweb.com'] = 'localhost';
        $impexconfig['source']['username on the database'] = 'username';
        $impexconfig['source']['password to phpbb database'] = 'password';
        $impexconfig['source']['phpbb database name'] = 'source';
        $impexconfig['source']['tableprefix'] = '';

        Comment


        • #5
          This is driving me insane..somebody please help. I tried doing this but it still wouldnt work:

          $impexconfig['source']['tableprefix'] = 'phpbb_';

          HELP PLEASE

          I tried getting back onto my old forum (phpbb) after installing vb and im getting these errors..perhaps this has something to do with it


          Warning: mysql_connect(): Access denied for user 'Vladi_1'@'10.0.98.74' (using password: YES) in /www/g/gameonlockco/htdocs/forum/db/mysql4.php on line 48

          Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /www/g/gameonlockco/htdocs/forum/db/mysql4.php on line 330

          Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /www/g/gameonlockco/htdocs/forum/db/mysql4.php on line 331
          phpBB : Critical Error

          Could not connect to the database

          Edit: I just took off all the impex files off my server and only put up the ones i need. Vb and phpbb2. I changed the config. Went to my hosting site and changed my database password BUT STILL I GET 'Connection to source server failed. Check username and password.'
          Last edited by Gameonlock.com; Fri 9 Dec '05, 7:21pm.

          Comment


          • #6
            Well first of all this should be set to 'true':

            $impexconfig['sourceexists']['TRUE'] = true;

            Also you need to look at the ImpExConfig.php.new file. You are adding a bunch of stuff that shouldn't be there, like the part in bold above.

            Don't edit anything to the left of the equal sign. The variables go to the right of the equal sign.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Oh alright thanks i realy realy hope that works cause if it doesnt ill go nuts!

              Yes! It worked thanks alot but now im getting other erros wen importing,.
              Last edited by Gameonlock.com; Fri 9 Dec '05, 8:42pm.

              Comment


              • #8
                lol join the club - nobody ever helps

                Comment


                • #9
                  Hardly we help tons

                  Comment


                  • #10
                    Originally posted by Zachery
                    Hardly we help tons
                    Can you help me on this topic please

                    Comment


                    • #11
                      Originally posted by rixthemix
                      lol join the club - nobody ever helps
                      Speak for yourself. When I moved from our old board and had a problem with the ImpEx script I had first class response from the team here.

                      Bob

                      Comment


                      • #12
                        im getting help at the moment but thanks for the comment

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X