Announcement

Collapse
No announcement yet.

Merging two seperate 3.5.1 boards?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Merging two seperate 3.5.1 boards?

    I have decided that I want to merge my 3.5.1 board with a friends vBulletin 3.5.1 board. Two completley diffrent boards at 2 diffrent domains just for clarification. Despite having a fair knowledge of vBulletin, ths instructions in the sticky how to thread really make no sense to me at all.

    So in some what simpler terms(then the how to thread) can some one explain to me how I go about making this merge with out screwing things up.

    I plan on trying to import my current forum into my test board a few times just to make sure that when it comes time ofr the actual merge itself I want screw things up.

  • #2
    Use ImpEx to import the data from one forum. To do that, upload the files, edit the config file and click yourself through the modules... it's not hard
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      Altering tables

      ImpEx will now Alter the tables in the vB database to include import id numbers.This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.They will also be left after the import if you need to link back to the origional vB userid.
      moderator - importmoderatorid Completed
      usergroup - importusergroupid Completed
      ranks - importrankid Completed
      poll - importpollid Completed
      forum - importforumid Completed
      forum - importcategoryid Completed
      user - importuserid Completed
      style - importstyleid Completed
      thread - importthreadid Completed
      post - importthreadid Completed
      thread - importforumid Completed
      smilie - importsmilieid Completed
      pmtext - importpmid Completed
      avatar - importavatarid Completed
      customavatar - importcustomavatarid Completed
      customprofilepic - importcustomprofilepicid Completed
      post - importpostid Completed
      attachment - importattachmentid Completed
      pm - importpmid Completed
      There seems to have been a problem with the database.
      ImpEx Database errormysql error: Invalid SQL: SHOW TABLES

      mysql error: No Database Selected

      mysql error number: 1046

      Date: Thursday 24th of November 2005 02:12:30 AM

      So I go to the import page in the admin cp. I select it to install from vB3 to 3.5.1. Then I click Import. Then when I click the first start module button, it gives me the error above. I am slightly confused on the set up on the config.php file so perhaps that is it?

      Comment


      • #4
        I am pretty sure my config file is correct. The top half is edited for the info of the target db and the scond hald has been edited to point to the source db.

        Comment


        • #5
          Originally posted by Xplorer4x4
          I am pretty sure my config file is correct. The top half is edited for the info of the target db and the scond hald has been edited to point to the source db.
          Just to ensure that ImpEx is using the ImpExConfig.php file, move the impex folder out of vBulletin and run it stand alone, i.e. in your webroot.
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            Done...Same error as before. So I should be running it from http://www.xxxxxxxx.net/impex/index.php correct?

            Comment


            • #7
              Originally posted by Xplorer4x4
              Done...Same error as before. So I should be running it from http://www.xxxxxxxx.net/impex/index.php correct?
              Don't post direct links its can be dangerous.

              But yes, like that.

              Though as that dosen't work I'd guess that some of the details in ImpExConfig are missing or incorrect.
              I wrote ImpEx.

              Blog | Me

              Comment


              • #8
                Normally I wouldn;t of posted the direct link but if you add 2(my sig)+2(impex dir and index.php) you get 4(the full url). But thanks for the concern. Anyways no I do not see hwo it is possible for my config file to be wrong.

                For reference, I went into my backup options on my cpanel it offers a full,home directorey,download a mysql,and download filters backup options. So I downloaded a sql back up of my main board that I will be merging. Then say it was called vbulletin.gz when i downloaded it I changed it to vbulletin2.gz and uploaded it in the restore an sql database option. Is it possible the manual renaming of the downloaded back up is causing a problem even though I set config.php to read vbulletin2 and not vbulletin?

                Comment


                • #9
                  I don't think that could be the case no, if your server is publicly accessible, start a support ticket with the FTP and admincp details and ask for me and I'll check and see what is going on.
                  I wrote ImpEx.

                  Blog | Me

                  Comment


                  • #10
                    Thanks alot Jerry.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X