Announcement

Collapse
No announcement yet.

impex error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • impex error

    im gettin this erro
    ImpEx Database errormysql error: cannot use database
    mysql error: No Database Selected
    mysql error number: 1046
    Date: Thursday 03rd of November 2005 04:25:23 AM

    please help me is urgent
    tx

  • #2
    Your db info in ImpExConfig.php is wrong. Recheck and edit this info.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      hey

      hey
      it is right
      <?php
      #################################################################### |;
      #
      # ---------------------------------------------------------------- # |;
      # Copyright ©2000–2005 Jelsoft Enterprises Ltd. All Rights Reserved. |;
      # This file may not be redistributed in whole or significant part. # |;
      # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # |;
      # http://www.vbulletin.com | http://www.vbulletin.com/license.html # |;
      #################################################################### |;
      # The following settings allow ImpEx to connect to the vBulletin 3
      # database into which you will be importing data.
      # If impex is installed in vBulletin you can ignore the target details
      # as includes/config.php
      $impexconfig['target']['databasetype'] = 'mysql';
      $impexconfig['target']['server'] = 'localhost';
      $impexconfig['target']['user'] = 'username';
      $impexconfig['target']['password'] = 'password';
      $impexconfig['target']['database'] = 'forum';
      $impexconfig['target']['tableprefix'] = '';

      # If the system that is being imported from uses a database,
      # enter the details for it here and set 'sourceexists' to TRUE.
      # If the source data is NOT stored in a database, set 'sourceexists' to FALSE
      $impexconfig['sourceexists'] = TRUE;
      # mysql / mssql
      $impexconfig['source']['databasetype'] = 'mysql';
      $impexconfig['source']['server'] = 'localhost';
      $impexconfig['source']['user'] = 'username';
      $impexconfig['source']['password'] = 'password';
      $impexconfig['source']['database'] = 'forums1';
      $impexconfig['source']['tableprefix'] = '';

      # Error logging will log import errors to a database table impexerror
      # for use with support.
      # Language file is the file of phrases to be used, default is english.
      # pagespeed is the second(s) wait before the page refreshes.
      $impexconfig['system']['errorlogging'] = true;
      $impexconfig['system']['language'] = 'impex/impex_language.php';
      $impexconfig['system']['pagespeed'] = 1;
      ?>
      Last edited by raagaswaram; Wed 2 Nov '05, 2:45pm.

      Comment


      • #4
        My guess is your source info is not correct. If it were correct you would not get that error.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          hey

          hey
          for source i have to put the database name ryte?
          of where the old db files are in and old forum hav to be running? or it doesn't hav to coz is not running
          tx

          Comment


          • #6
            What are you trying to import? The 'source' is the database you want to import into vB.

            Please view the online instructions here:
            http://www.vbulletin.com/docs/html/impex

            Please view the 'After the Import' instructions here:
            http://www.vbulletin.com/docs/html/impex_cleanup
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              im tryin to import

              hey
              im trying to import anothe vb 3.0.9 tables to this vb 3.0.9
              because my template was messed for osmethin so i hav to reinstall all over agin to see if is the template or the forum messing now it is fixed so i want to import all the users n stuff
              tx

              Comment


              • #8
                hey

                hey
                plz mesg asap
                tx

                Comment


                • #9
                  You need to follow the Impex instructions and use the correct db info.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    hey

                    hey
                    i did follow that im still getting that error
                    thank you

                    Comment


                    • #11
                      Does the user have the correct permissions to access the database ?
                      I wrote ImpEx.

                      Blog | Me

                      Comment


                      • #12
                        hey

                        hey
                        yes it has full permission
                        thank you

                        Comment


                        • #13
                          Originally posted by raagaswaram
                          hey
                          yes it has full permission
                          thank you
                          Then the database name or the user/pass must be incorrect.
                          I wrote ImpEx.

                          Blog | Me

                          Comment


                          • #14
                            hey

                            hey
                            i checked everythin is all correct
                            thank you

                            Comment


                            • #15
                              All I can suggest is starting a support ticket so we can take a look and diagnose why ImpEx can't select the database correctly.
                              I wrote ImpEx.

                              Blog | Me

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X