Announcement

Collapse
No announcement yet.

Admin CP not updated for Impex

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin CP not updated for Impex

    Hello,

    I have just installed vBulletin 3.5 and Impex, but the Admin CP doesn't show the Maintenance->Import/Export link as instructed:
    "From your Admin Control Panel (admincp/ by default), select Maintenance > Import / Export and select the system you wish to import, from the list."

    I did copy the upload/includes/xml/cpnav_impex.xml file to the vbulletin/includes/xml directory. The ASCII mode file transfer was confirmed by re-uploading it in ASCII mode. The folder now contains the following:
    bitfield_vbulletin.xml
    cpnav_impex.xml
    cpnav_vbulletin.xml
    hooks_vbulletin.xml
    index.html
    js_safe_phrases.xml
    spiders_vbulletin.xml

    What do I need to check to solve this problem?

    Thanks.
    Last edited by parafieldtower; Mon 3rd Oct '05, 5:40am.

  • #2
    Hello,

    Apparently the Import link is right at the top left, under its own Import category rather than under Maintenance. Nevertheless, I still get the following:
    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.
    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.
    We apologise for any inconvenience.

    Comment


    • #3
      Right Click, view source, paste error message.


      Also you have configured your impexconfig.php file correct?

      Comment


      • #4
        Yes I have configured impexconfig.php. I typed in the variables for the server, database name, user, password, table prefix, etc. I also changed this variable to true.

        Thanks


        <html><head><title> Database Error</title><style type="text/css"><!--.error { font: 11px tahoma, verdana, arial, sans-serif; }--></style></head>
        <body></table></td></tr></table></form>
        <blockquote><p class="error">&nbsp;</p><p class="error"><b>There seems to have been a slight problem with the database.</b><br />
        Please try again by pressing the <a href="javascript:window.location=window.location;">refresh</a> button in your browser.</p><p class="error">An E-Mail has been dispatched to our <a href="<A href="mailto:">Technical">mailto:">Technical Staff</a>, who you can also contact if the problem persists.</p><p class="error">We apologise for any inconvenience.</p></blockquote>
        <!--
        Database error in vBulletin:ImpEx Target :
        Invalid SQL: CREATE TABLE `vbulletinvbfields` (
        `fieldname` varchar(50) NOT NULL default '',
        `tablename` varchar(20) NOT NULL default '',
        `vbmandatory` enum('Y','N','A') NOT NULL default 'N',
        `defaultvalue` varchar(200) default 'NULL',
        `dictionary` mediumtext NOT NULL
        );

        mysql error: You have an error in your SQL syntax near ';
        ' at line 7
        mysql error number: 1064
        Date: Monday 03rd of October 2005 06:01:12 AM
        Script: http://www.canreef.com/vbulletin/impex/index.php
        Referer: http://www.canreef.com/vbulletin/admincp/index.php
        IP Address: 220.253.117.174
        -->
        </body></html>

        Comment


        • #5
          Download impex again, upload and over write vbfields.php.
          I wrote ImpEx.

          Blog | Me

          Comment


          • #6
            Hello,

            I did that but still am having the same problem:
            <html><head><title> Database Error</title><style type="text/css"><!--.error { font: 11px tahoma, verdana, arial, sans-serif; }--></style></head>
            <body></table></td></tr></table></form>
            <blockquote><p class="error">&nbsp;</p><p class="error"><b>There seems to have been a slight problem with the database.</b><br />
            Please try again by pressing the <a href="javascript:window.location=window.location;">refresh</a> button in your browser.</p><p class="error">An E-Mail has been dispatched to our <a href="<A href="mailto:">Technical">mailto:">Technical Staff</a>, who you can also contact if the problem persists.</p><p class="error">We apologise for any inconvenience.</p></blockquote>
            <!--
            Database error in vBulletin:ImpEx Target :
            Invalid SQL: CREATE TABLE `vbulletinvbfields` (
            `fieldname` varchar(50) NOT NULL default '',
            `tablename` varchar(20) NOT NULL default '',
            `vbmandatory` enum('Y','N','A') NOT NULL default 'N',
            `defaultvalue` varchar(200) default 'NULL',
            `dictionary` mediumtext NOT NULL
            );

            mysql error: You have an error in your SQL syntax near ';
            ' at line 7
            mysql error number: 1064
            Date: Tuesday 04th of October 2005 02:22:42 AM
            Script: http://www.canreef.com/vbulletin/impex/index.php
            Referer: http://www.canreef.com/vbulletin/admincp/index.php
            IP Address: 220.253.117.174
            -->
            </body></html>

            Comment


            • #7
              Manully edit vbfields.php... and change ); to just ) and try again. Worked for me.

              $queries[] = "CREATE TABLE `{$tableprefix}vbfields` (
              `fieldname` varchar(50) NOT NULL default '',
              `tablename` varchar(20) NOT NULL default '',
              `vbmandatory` enum('Y','N','A') NOT NULL default 'N',
              `defaultvalue` varchar(200) default 'NULL',
              `dictionary` mediumtext NOT NULL)
              Last edited by cujo; Tue 4th Oct '05, 9:01am.
              _________________
              ΜΟΛΩΝ ΛΑΒΕ

              Comment


              • #8
                This has been fixed, if you are getting this error you have an old version of impex.
                I wrote ImpEx.

                Blog | Me

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X